lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-29-2008, 12:44 PM   #1
Loud & Lifted
Here for the beer
 
Loud & Lifted's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Damon Texas
Posts: 1,459
Default Starter/Generator not charging.

Doesnt seem like me starter/gen is charging the battery. I put a meter on the battery,put the cart in nuetral and gave it gas and didnt seem like it was charging. I thinkin its the brushes. What do ya'll think?
Loud & Lifted is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-29-2008, 12:46 PM   #2
spriddle
Admin
 
spriddle's Avatar
Yamaha
 
Join Date: Dec 2006
Location: TN
Posts: 101,457
Default Re: Starter/Generator not charging.

That's exactly what it sounds like to me.

spriddle is offline   Reply With Quote
Old 09-29-2008, 02:14 PM   #3
Big Bump
Getting Wild
 
Join Date: Mar 2008
Posts: 90
Default Re: Starter/Generator not charging.

I would think that if the brushes are good enough to run the
starting side, they should be good enough to do the charging
part. Sounds like voltage regulator to me.
Big Bump is offline   Reply With Quote
Old 09-29-2008, 02:18 PM   #4
spriddle
Admin
 
spriddle's Avatar
Yamaha
 
Join Date: Dec 2006
Location: TN
Posts: 101,457
Default Re: Starter/Generator not charging.

Actually, big bump is correct, if it will run the engine with no problems. I don't know what I was thinking for a minute.

spriddle is offline   Reply With Quote
Old 09-29-2008, 08:47 PM   #5
ruredy
Born Wild
 
ruredy's Avatar
 
Join Date: Mar 2007
Location: Clover SC.
Posts: 5,552
Default Re: Starter/Generator not charging.

to test for bad vr take the green wire off the start/gen and ground it to the frame. test voltage at the battery while the engine is running, will read around 16v if the vr is bad
ruredy is offline   Reply With Quote
Old 09-30-2008, 07:10 AM   #6
Loud & Lifted
Here for the beer
 
Loud & Lifted's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Damon Texas
Posts: 1,459
Default Re: Starter/Generator not charging.

Thanks for the info guys. I'll check the vr when I get home tonite. I figured it was one of the two causin the problem. No sense in throwin parts at it till its fixed. That gets expensive.
Loud & Lifted is offline   Reply With Quote
Old 07-06-2009, 01:13 PM   #7
thevoth
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2009
Location: Ontario Canada
Posts: 13
Default Re: Starter/Generator not charging.

I have an 84 marathon and I get a varible reading in the charging circut I have tried grounding the common feild wire (green) from the generator and still get a reading that jumps al over. could the soliniod be bad?
dv
thevoth is offline   Reply With Quote
Old 08-19-2020, 08:09 PM   #8
GoBeau
Not Yet Wild
Club Car
 
Join Date: Sep 2015
Location: Ontario, CANADA
Posts: 21
Default Re: Starter/Generator not charging.

Quote:
Originally Posted by thevoth View Post
I have an 84 marathon and I get a varible reading in the charging circut I have tried grounding the common feild wire (green) from the generator and still get a reading that jumps al over. could the soliniod be bad?
dv
Just curious, did you ever find out what was the cause of the battery not charging? Having similar problems and also was wondering if the Solinoid could be the issue. Have change the Battery, Starter/Generator and Voltage Regulator and belts..... still having an issue with battery not charging. Thanks.
GoBeau is offline   Reply With Quote
Old 08-20-2020, 01:33 PM   #9
cart around
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 3,361
Default Re: Starter/Generator not charging.

Quote:
Originally Posted by GoBeau View Post
Just curious, did you ever find out what was the cause of the battery not charging? Having similar problems and also was wondering if the Solinoid could be the issue. Have change the Battery, Starter/Generator and Voltage Regulator and belts..... still having an issue with battery not charging. Thanks.

The solenoid has one purpose. That is to pass current from the battery to the starter. It stays engaged the entire time the engine is running. That means that if your starter is turning, and your engine is running..... There is nothing wrong with your solenoid.
cart around is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
91 Marathon Starter/Generator ? Gas EZGO
1987 EZGO -- needs starter /generator ?? Golf Carts and Parts
Wanted: 91 3pg Starter / Generator Golf Carts and Parts
starter/generator smoking Gas EZGO
G16+ Starter/Generator Golf Carts and Parts


All times are GMT -5. The time now is 12:40 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.