lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-01-2014, 04:28 PM   #1
rangersam
Not Yet Wild
Star
 
Join Date: Jun 2014
Location: Phoenix
Posts: 13
Default 2010 Star Car stopped

Hello: I have a 2010 Star golf car, 48 volts. Yesterday a couple times I depressed the gas(electric) pedals and nothing happened and then it slowly took off to full speed when pressed a couple times. Also yesterday a few times is just sort of started to move and eventually sped up. It only happened about 4 times during the round of golf. Today, I got through 5 holes and it started to do that again. Then on hole number 6 it died. had to tow it off the golf course. Any ideas? The cart was working great up until yesterday. I'm in Phoenix, 100 degrees if that means anything? Also, I charged up the batteries after that first instance and when I got in the cart this morning it was down 3 bars? Thanks for any assistance. rangersam
rangersam is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-02-2014, 02:04 PM   #2
rangersam
Not Yet Wild
Star
 
Join Date: Jun 2014
Location: Phoenix
Posts: 13
Default Re: 2010 Star Car stopped

I tested the batteries and they all have just over 6 volts charge. I also looked in the back and saw the DC Motor Controller. The yellow status light was blinking 5 times twice in a row, then paused, did the same 5 blinking twice pausing over again and again. The only time it stopped was when I plugged in the charger to see if it kept blinking. rangersam
rangersam is offline   Reply With Quote
Old 06-02-2014, 06:06 PM   #3
rangersam
Not Yet Wild
Star
 
Join Date: Jun 2014
Location: Phoenix
Posts: 13
Default Re: 2010 Star Car stopped

I call up a local dealer for Star and he tells me it may be the solenoid or controller, solenoid being around $300.00 and controller around $1,000.00. He questioned the blinking yellow status light on the controller, asked if it were green or red? Anyone know about what color the light should be on the controller? Thanks, rangersam
rangersam is offline   Reply With Quote
Old 06-03-2014, 09:18 AM   #4
mlj427
Gone Wild
 
Join Date: Jan 2009
Location: Southern Maryland
Posts: 378
Default Re: 2010 Star Car stopped

I am not one of the experts on here but it could be battery related. Fully charged a 6 volt battery I think is 6.37 volts thats 100% charged but 6.05 is 50% charged so a little over 6v could be real low. Also check for any looseness in the battery terminals or corrosion. Put the cart in tow mode if you need to take any terminals loose to clean them, so you do not shock the controller.
Good luck
Mike
mlj427 is offline   Reply With Quote
Old 06-03-2014, 12:11 PM   #5
rangersam
Not Yet Wild
Star
 
Join Date: Jun 2014
Location: Phoenix
Posts: 13
Default Re: 2010 Star Car stopped

Thanks Mike! I'm in the process of checking the batteries more. I learned how to test them all and it came out to 51.2 volts, wondering if that's a good number or not. Before the cart started acting up it was running really well, as fast as new so I may try the Solenoid first, thinking I may save some money, but when I called the shop and he said a Solenoid would be around $300.00 and a controller around $1,000.00, I went in panic mode about the controller!
rangersam is offline   Reply With Quote
Old 06-03-2014, 09:48 PM   #6
mlj427
Gone Wild
 
Join Date: Jan 2009
Location: Southern Maryland
Posts: 378
Default Re: 2010 Star Car stopped

A lot of parts are available from suppliers on here. I bet the solenoid is the same as one for a ezgo just looked at one sponsor and the most expensive was under $80. that I saw. So shop around and ask them questions maybe they can tell you which will work. You might even cross reference from the part numbers on the solenoid. And the controller can usually be rebuilt. If not you could upgrade to a Alltrax performance model for less then $1000.
Mike
mlj427 is offline   Reply With Quote
Old 06-15-2014, 09:34 AM   #7
rangersam
Not Yet Wild
Star
 
Join Date: Jun 2014
Location: Phoenix
Posts: 13
Default Re: 2010 Star Car stopped

Thanks Mike, just got back from a short vacation and starting up on this again. I appreciate your help. I'm probably going to post again about the blinking status light on the controller to see if I can get any help? rangersam
rangersam is offline   Reply With Quote
Old 06-16-2014, 02:56 PM   #8
rangersam
Not Yet Wild
Star
 
Join Date: Jun 2014
Location: Phoenix
Posts: 13
Default Re: 2010 Star Car stopped

Okay, so this is weird! I'v been gone 11 days, came home and tried the cart, still dead, although everything was the same. The lights were still blinking and when I pressed on the pedal I could hear a faint click in the back, but nothing. The cart had been sitting at my sister in laws house which is right around the corner from us, about .3 of a mile away. I towed the cart to our house with her cart and put it in the garage, there were a couple bumps on the way if that means anything? Was looking in the back at the solenoid and controller, (which I've been doing a lot of lately), put the key in, pressed the pedal, got a louder click and the cart moved. Took a ride up and down the block, still running. Is the solenoid going or what? Sort of scared to try a round of golf with it? Thanks, rangersam
rangersam is offline   Reply With Quote
Old 06-17-2014, 09:16 AM   #9
rangersam
Not Yet Wild
Star
 
Join Date: Jun 2014
Location: Phoenix
Posts: 13
Default Re: 2010 Star Car stopped

Purchased a new solenoid, installed and working like before, a much louder click when I press the pedal. Gonna take it out for a ride each day several times before I hit the golf course with it. No blinking lights on the controller and the power indicator seems to be working better? Thanks, rangersam
rangersam is offline   Reply With Quote
Old 02-29-2016, 08:31 PM   #10
rangersam
Not Yet Wild
Star
 
Join Date: Jun 2014
Location: Phoenix
Posts: 13
Default Re: 2010 Star Car stopped

Hi all! I still have this Star Cart and the batteries are getting old. Can barely do a round of golf on them, so I was going to check on replacing them. The cart came with Trojans and figured I'd put in the same. The other day it just barely moved for me after completing almost a full round and after a complete charge. The indicator says full, I tested each battery, 6.0 to 6.1 and the whole series was 48.1 volts, but the cart won't move. Headlights are bright as can be. I'm no electrician, does it have something to do with AMPs or ???? Even though the volts say good? Thanks for any advice before I replace the batteries. RangerSam
rangersam is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Thread Tools
Display Modes


Similar Threads
Thread Forum
2010 star cart head lamp replacement Star and Fairplay
2010 Star Golf Cart For sale. 48 Volt Street Legal Golf Carts and Parts
Steering Wheel for 2010 Star Cart Star and Fairplay
2010 star pictures Star and Fairplay
When you wish upon a star.... Golf Carts and Parts


All times are GMT -5. The time now is 04:31 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.