lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 05-06-2015, 10:11 AM   #1
CAPTAINASU
Not Yet Wild
 
Join Date: Jan 2013
Posts: 18
Default Starts great, runs great, then dies

I have done several searches but I can seem to find anything that addresses the problem I am experiencing. My Marathon starts right up even after weeks, or months, of being parked. Once started it runs great about 3 out of 4 times.

The other time it starts and runs great but with sometimes die while running as if the key has been turned off. No misfire, sputtering, etc. just flat dead. Once I come to a stop I turn the key off and on a couple of times and take in in out out of gear and it usually starts right back up with no problem.

I'm 99% sure this is an electrical bug somewhere but nothing is obvious when's check connections or grounds. Anyone have suggestions on where to start when chasing down this issue?
CAPTAINASU is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 05-06-2015, 12:37 PM   #2
sccowboy
It ain't gonna be easy.
 
sccowboy's Avatar
E-Z-GO
 
Join Date: Apr 2008
Location: St. George, SC
Posts: 1,473
Default Re: Starts great, runs great, then dies

I seem to remember someone had a similar problem and it ended up being the key switch.
sccowboy is offline   Reply With Quote
Old 05-06-2015, 02:42 PM   #3
CAPTAINASU
Not Yet Wild
 
Join Date: Jan 2013
Posts: 18
Default Re: Starts great, runs great, then dies

I'll start there and let you know what I find

Thanks
CAPTAINASU is offline   Reply With Quote
Old 05-06-2015, 04:36 PM   #4
sccowboy
It ain't gonna be easy.
 
sccowboy's Avatar
E-Z-GO
 
Join Date: Apr 2008
Location: St. George, SC
Posts: 1,473
Default Re: Starts great, runs great, then dies

One other thought, when it does that, does the starter still engage or is it completely dead. If its dead it could also point to a bad solenoid.
sccowboy is offline   Reply With Quote
Old 05-07-2015, 07:22 AM   #5
racin161
Gone Wild
 
Join Date: Feb 2011
Posts: 1,515
Default Re: Starts great, runs great, then dies

Try dirty forward/reverse switch Spray cleaner on the contacts move it forward/reverse several times. You may have to repeat a few times.

LOU
racin161 is offline   Reply With Quote
Old 05-07-2015, 08:56 AM   #6
Jeff Duncan
Not Yet Wild
 
Join Date: May 2015
Posts: 5
Default Re: Starts great, runs great, then dies

I have a similar problem; runs for a few minutes at WOT and dies, next time less time, on and on but will sputter and backfire too.

I'm no mechanic and where I'm form in Canada there's few with experience with these.

Good luck.
Jeff Duncan is offline   Reply With Quote
Old 05-07-2015, 09:39 AM   #7
nobuckbuild
Gone Wild
 
nobuckbuild's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: CENTRAL PENNSYLVANIA
Posts: 1,466
Default Re: Starts great, runs great, then dies

check the wire connectors on the coil and from the pulsar coil , common corrosion issue will take out spark at random and come right back
nobuckbuild is offline   Reply With Quote
Old 05-07-2015, 01:50 PM   #8
sccowboy
It ain't gonna be easy.
 
sccowboy's Avatar
E-Z-GO
 
Join Date: Apr 2008
Location: St. George, SC
Posts: 1,473
Default Re: Starts great, runs great, then dies

Maybe this will help you:

sccowboy is offline   Reply With Quote
Old 05-07-2015, 01:52 PM   #9
sccowboy
It ain't gonna be easy.
 
sccowboy's Avatar
E-Z-GO
 
Join Date: Apr 2008
Location: St. George, SC
Posts: 1,473
Default Re: Starts great, runs great, then dies

Or this one which is from the mid 80s:

sccowboy is offline   Reply With Quote
Old 05-07-2015, 01:55 PM   #10
cart around
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 3,309
Default Re: Starts great, runs great, then dies

Looks like this thread is dealing with two different carts, and we still have no idea if we are dealing with 2 strokes, or 4 strokes.
cart around is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
87 Columbia Gas, Runs Great, then VERY SLOW, then great Gas Columbia ParCar
Starts great no power after rebuild Gas Harley Davidson
G1, idles great, runs rough, runs better when warm Gas Yamaha
86 Columbia Goes Great then Dies Gas Columbia ParCar
Fe 290 runs great then smokes then great?? Gas Club Car


All times are GMT -5. The time now is 11:25 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.