lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-07-2016, 05:25 PM   #1
honcho
Not Yet Wild
 
Join Date: Jan 2016
Posts: 46
Default Got a weird sound

Man jumped in cart today and have a weird sound coming from either my drivers side wheel or the rear end itself. Sounds like metal rubbing on metal. I don't think its the hub as I have replaced it 2 yrs ago. I can't remember if there are bearings in there or not??? Thanks in advance for any insight of what this may be,also the cart itself does not roll smoothly, it surges when you drive it,if that makes any sense
honcho is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 02-07-2016, 05:37 PM   #2
crash test dummy
Not Yet Wild
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 0
Default Re: Got a weird sound

check your brakes , i have had a brake pad fall off
crash test dummy is offline   Reply With Quote
Old 02-07-2016, 06:30 PM   #3
hondarider203
Gone Wild
 
hondarider203's Avatar
Club Car
 
Join Date: Dec 2015
Location: Farmdale ohio
Posts: 285
Default Re: Got a weird sound

Could also be something in the breaks causing a grinding sound?? Had it happen to multiple vehicles
hondarider203 is offline   Reply With Quote
Old 02-07-2016, 06:34 PM   #4
honcho
Not Yet Wild
 
Join Date: Jan 2016
Posts: 46
Default Re: Got a weird sound

Yea I won't be able to do that till next weekend,are there bearings back there,I can't remember
honcho is offline   Reply With Quote
Old 02-07-2016, 06:38 PM   #5
crash test dummy
Not Yet Wild
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 0
Default Re: Got a weird sound

in the axle
crash test dummy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
95 ezgo making weird sound.inside control box not moving Electric EZGO
Weird noise, sound...pls help!! Electric EZGO
lifted my cart today and not I am getting a weird noise and grinding sound Gas EZGO
2004 Club Car IC making weird sound Electric Club Car


All times are GMT -5. The time now is 01:14 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.