lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-02-2019, 03:36 PM   #1
Coolhand104
Not Yet Wild
 
Join Date: Jul 2018
Posts: 14
Default 2010 Yamaha Drive 48v does nothing

Hopefully someone can help me. I have a 2010 Yamaha G29 48 volt golf cart with 4 12v Trojan batteries. The pack voltage is at 51v. The cart does absolutely nothing. It doesnít beep when I push when run switch is on. The solenoid doesnít click at all either. I have replaced the controller and solenoid from another 2010 G29 that works and still nothing. There is power on both sides of the key switch. Anyone have any ideas? Thanks in advance!
Coolhand104 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-02-2019, 03:38 PM   #2
Coolhand104
Not Yet Wild
 
Join Date: Jul 2018
Posts: 14
Default Re: 2010 Yamaha Drive 48v does nothing

Forgot to mention that there is pack voltage on the right large stud of the solenoid but no power on the large stud that is connected to the controller.
Coolhand104 is offline   Reply With Quote
Old 07-03-2019, 06:31 AM   #3
TXWELDER
Gone Wild
 
Join Date: Apr 2019
Posts: 192
Default Re: 2010 Yamaha Drive 48v does nothing

Signal from the throttle? F&R switch functional?
TXWELDER is offline   Reply With Quote
Old 07-03-2019, 08:36 AM   #4
Coolhand104
Not Yet Wild
 
Join Date: Jul 2018
Posts: 14
Default Re: 2010 Yamaha Drive 48v does nothing

Thanks for the response. Would that cause the solenoid not to click when switching between run/tow?
Coolhand104 is offline   Reply With Quote
Old 07-03-2019, 09:57 AM   #5
NCPW
Just Gone
 
NCPW's Avatar
Club Car
 
Join Date: Sep 2015
Location: North Carolina
Posts: 3,547
Default Re: 2010 Yamaha Drive 48v does nothing

Have you tried tapping on the solenoid with the wooden end of a hammer to see if it's possibly stuck open?

Recheck all connections to make sure every thing is tight and no loose/frayed wires/cables.
NCPW is offline   Reply With Quote
Old 07-03-2019, 12:13 PM   #6
Coolhand104
Not Yet Wild
 
Join Date: Jul 2018
Posts: 14
Default Re: 2010 Yamaha Drive 48v does nothing

I have not tried tapping the solenoid but I swapped it with one from a working G29. Iíll look over all the connections next I guess. Thanks
Coolhand104 is offline   Reply With Quote
Old 09-14-2019, 02:49 PM   #7
Coolhand104
Not Yet Wild
 
Join Date: Jul 2018
Posts: 14
Default Re: 2010 Yamaha Drive 48v does nothing

If anyone can help, I’m still stuck trying to figure out what’s wrong with my cart. I have change the controller with yet again another one that I bought online used. Still nothing! One thing I did notice is that the reverse beeper makes a constant beep when I have the plug for the controller halfway in....but only in run mode. If it is beeping and run and I change to tow the beeping stops. I looked at all the wiring and I see no obvious issues. Could the plug be bad? I still get no resistance when trying to push the cart in run mode and no beep.
Coolhand104 is offline   Reply With Quote
Old 09-16-2019, 09:49 AM   #8
mcmillanjl
Not Yet Wild
 
mcmillanjl's Avatar
Yamaha
 
Join Date: Jul 2019
Location: South Carolina
Posts: 28
Default Re: 2010 Yamaha Drive 48v does nothing

Similar to what NCPW said, thoroughly check and test all of you wiring and components for bad connections due to loose fittings or corrosion.

You should be able to find a wiring diagram on some earlier posts, I would start there. Take your meter and check the + wire, and remember to always have your neg side of the meter touching your pack negative.

Start with run/tow switch, then all dash components and buzzer, then move to pedal assy (stop/throttle switch). Keep us updated
mcmillanjl is offline   Reply With Quote
Old 09-16-2019, 02:51 PM   #9
Coolhand104
Not Yet Wild
 
Join Date: Jul 2018
Posts: 14
Default Re: 2010 Yamaha Drive 48v does nothing

Thank you. I am going to change out the wire harness and see what happens. I will definitely update when I find the problem
Coolhand104 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
2010 Yamaha Drive Transaxle Oil Change Electric Yamaha
2010 Yamaha Drive has gone herky/jerky Electric Yamaha
2010 Yamaha Drive has gone herky/jerky Electric Yamaha
Painted my 2010 Yamaha Drive top today Body and Paint
New to me 2010 Yamaha Drive JW2-308##### Electric Yamaha


All times are GMT -5. The time now is 03:51 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.