lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 03-10-2010, 10:50 PM   #1
sowdersd
Not Yet Wild
 
Join Date: Dec 2008
Posts: 4
Default 87 EZGO 2 stroke won't start

Just finished rebuilding an 87 EZGO 2 stroke, and when I say rebuilt, I mean new crank, piston assy, new cylinder, head, crank seals, rebuilt carb, etc. Cranked it over without spark plug to allow fuel pump to fill the lines and fill the carb. I used a see-through filter so I can tell there is fuel flow. While plug was out, I watched gap for spark, while cranking the engine over, which there was. Once I felt the carb bowl was full, I put the spark plug back in and tightened it down.

Started cranking it over again and it started running right away, but not wanting to seem go much more than idle. Before I could try anything, the engine produced a loud "POP" like a back fire, had some smoke come from it (couldn't tell source). Now, it still cranks over just fine, but will not start. After checking several items, I pulled the air filter intake off the carb and started cranking it over again. I place my hand near the intake and felt no air flow, no induction of air. I sprayed just a touch of ether at the intake to see if it would start of of that... it didn't. I checked the spark, it is still there.

I pulled the carb, intake and reed valves to see if they were sealing, and they looked ok. Put all of those back on with new gaskets, torqued down, tried starting the engine again, cranks over just fine, but will not start.

What would prevent the engine from not pulling air through the carb? I'm thinking of taking off the muffler to see if it is somehow blocked.

Any other ideas out there? Thank you for your help.
sowdersd is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 03-11-2010, 07:32 AM   #2
ruredy
Born Wild
 
ruredy's Avatar
 
Join Date: Mar 2007
Location: Clover SC.
Posts: 5,552
Default Re: 87 EZGO 2 stroke won't start

sounds like you blew out the crank seals. any breach in the crankcase and the engine will fail to draw the fuel mix through it.
ruredy is offline   Reply With Quote
Old 03-11-2010, 10:19 AM   #3
FIXEROFCARTS
Gone Wild
 
Join Date: Feb 2009
Location: Not sure yet
Posts: 500
Default Re: 87 EZGO 2 stroke won't start

My first thought too is blown out crank seal. Also, did you use lots of 2 stroke oil as assmbly lube? Did you premix the fuel? Check compression just for #hits and grins
FIXEROFCARTS is offline   Reply With Quote
Old 03-11-2010, 07:20 PM   #4
sowdersd
Not Yet Wild
 
Join Date: Dec 2008
Posts: 4
Default Re: 87 EZGO 2 stroke won't start

ruredy and FixerofCarts.. yes, used 2-stroke oil as you mentioned, fuel was pre-mixed to 50:1, although I had my reservations about that, but that's what my boss said to do. Compression was 110 or so.
I pulled the exhaust pipe off this morning, just to visually check the cylinder and piston skirting. I could hear compression and suction as I rolled the engine around by hand.

My original thoughts were crank seals, but again, I was told , "look elsewhere". I can see the crank seal on the clutch side, appears to be in place, no bulging or signs of defect. I can't, however, see the seal on the flywheel side, which means either pulling the engine again to pull the flywheel, or try and work the puller in and around the engine compartment... no fun, either way.

As a side note, is there a "dead on" pre-setting for the inductive coupling, since the plate it is mounted to has slots where the screws go through? I marked the holes before I pulled the plate, but that doesn't mean it was set right to begin with.

Appreciate your help. Steve
sowdersd is offline   Reply With Quote
Old 03-11-2010, 08:33 PM   #5
FIXEROFCARTS
Gone Wild
 
Join Date: Feb 2009
Location: Not sure yet
Posts: 500
Default Re: 87 EZGO 2 stroke won't start

Have you checked to make sure you put the piston in right?
FIXEROFCARTS is offline   Reply With Quote
Old 03-11-2010, 09:12 PM   #6
sowdersd
Not Yet Wild
 
Join Date: Dec 2008
Posts: 4
Default Re: 87 EZGO 2 stroke won't start

Yes, the port in the piston went to the carburetor side... at least that's the direction that the other one came out. We don't have manuals, where I work, they have zero manuals, depend on calling primary manufacturers service dept. Really frustrating when you have to call all the time for spec's and general knowledge on simple things, but without the manuals and diagrams to be sure of...... my background in engines is pretty extensive, but without the manuals and the factory information, anything you do is best guess. The idea of "it worked that way when you took it out" just doesn't fly with me.....
sowdersd is offline   Reply With Quote
Reply

Tags
no airflow through carb, no induction, no intake
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
can i use 2 stroke ezgo clutch on 4 stroke Big Block Talk!
86 2 stroke hard to start(has to be full throttle) Gas EZGO
91 2-Stroke EZ GO Motor Rebuild Wont Start Gas EZGO
Start Up Problem-88 Ez-go 2 Stroke Gas EZGO
Please help with no start 93 2 stroke Gas EZGO


All times are GMT -5. The time now is 08:49 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.