lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 01-19-2013, 02:05 PM   #1
Dmontgomery
Gone Wild
E-Z-GO
 
Join Date: Nov 2012
Location: North Carolina
Posts: 161
Angry need help starter/ generator problems

I have just got my cart all back together (88 ezgo). I had the engine out to replace the crank seals when I removed the starter I left everything hooked up and CAREFULLY set it aside . I even ran it last night for 30 seconds or so with the drive belt off all was great. Went out this morning put the drive belt on and the starter would turn but very slow and weak so I charged the battery with same results. I even tried a brand new battery the wire labeled A2 is getting extremely hot and smoking a little. I took the wire off carefully with 2 wrenches and cleaned it didnt change anything what should I do next?
Dmontgomery is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 01-19-2013, 02:24 PM   #2
Vavoomskill
Gone Wild
 
Vavoomskill's Avatar
E-Z-GO
 
Join Date: Dec 2012
Location: Warren Mi
Posts: 233
Default Re: need help starter/ generator problems

Clean all the connections one by one... to start,, and check the grounds on the frame.
Vavoomskill is offline   Reply With Quote
Old 01-19-2013, 03:38 PM   #3
Dmontgomery
Gone Wild
E-Z-GO
 
Join Date: Nov 2012
Location: North Carolina
Posts: 161
Default Re: need help starter/ generator problems

Ok I will do, they dont seem to want to come off to easy imagine that!! There is only the one ground wire to the frame that goes into the fan housing? Right? Been a few weeks since I pulled engine and this is the first time ive ever done this
Dmontgomery is offline   Reply With Quote
Old 01-20-2013, 06:25 AM   #4
racin161
Gone Wild
 
Join Date: Feb 2011
Posts: 1,515
Default Re: need help starter/ generator problems

The main ground from the battery goes to the welded tab on the frame and is joined there with the one going to the fan housing. YES ?? clean all of them. You may also look at cleaning the f/r switch with carb spray or brake cleaner moving it forward and reverse while spraying then blowing it out with compressed air. Do it a few times and see what happens doesn't cost much.

LOU
racin161 is offline   Reply With Quote
Old 01-20-2013, 07:04 AM   #5
Dave Box
Respect the Cart
 
Dave Box's Avatar
E-Z-GO
 
Join Date: May 2010
Location: Rocky Mount, Virginia
Posts: 2,189
Default Re: need help starter/ generator problems

There should be three wires on the ground point.
One from the battery negative
One to any point on the engine block (and that needs to be a good ground or the engine will try to ground out through the chock cable and fail)
One to terminal C on the FNR switch. You didn't mention this one.

Dave
Dave Box is offline   Reply With Quote
Old 01-20-2013, 08:31 AM   #6
Dmontgomery
Gone Wild
E-Z-GO
 
Join Date: Nov 2012
Location: North Carolina
Posts: 161
Default Re: need help starter/ generator problems

Well went out early this morning and started cleaning and checking connectors and the wire F1 coming from the starter broke off in my hand, at the end that goes to the fnr switch the wires are very brittle I will order some new ones. I doubt that this is my problem, i couldnt get that lucky lol guess I will be waiting to see if those new crank seals helped my other issue. How can I check the brushes? I removed the tab and looked in but didnt really know what I was looking for??
Dmontgomery is offline   Reply With Quote
Old 01-20-2013, 08:51 AM   #7
tabaker
Not Yet Wild
E-Z-GO
 
Join Date: Jan 2013
Location: Sterling, IL.
Posts: 15
Default Re: need help starter/ generator problems

If you try the carb/brake cleaner be careful! Its very flammable. One spark and you will have a nice fire. It ran without the drive belt on? I would pull that drive belt back off and try it again.
tabaker is offline   Reply With Quote
Old 01-20-2013, 02:22 PM   #8
Dmontgomery
Gone Wild
E-Z-GO
 
Join Date: Nov 2012
Location: North Carolina
Posts: 161
Default Re: need help starter/ generator problems

Cleaned everything still starter will barely turn then just stop if the brushes are as bad as the cables its sure not going to hurt I will definitely need help doing that so I got some wire and connectors and new brushes ordered hope this doesnt turn out like trying to get the fan and clutch off....just how hard is it to put brushes in a Hitachi starter generator? Looking back it does seem that the starter was getting weaker over time and I had to turn it over quite a bit to get it to fire after I put the engine back in maybe just enough to do it in again thanks for the input
Dmontgomery is offline   Reply With Quote
Old 01-20-2013, 05:13 PM   #9
Dmontgomery
Gone Wild
E-Z-GO
 
Join Date: Nov 2012
Location: North Carolina
Posts: 161
Default Re: need help starter/ generator problems

This is what the brushes look like. Do they look worn enough to cause the starter to barely turn? Or am I on another wild goose chase
Attached Images
File Type: jpg image.jpg (216.8 KB, 0 views)
Dmontgomery is offline   Reply With Quote
Old 01-20-2013, 07:21 PM   #10
Dmontgomery
Gone Wild
E-Z-GO
 
Join Date: Nov 2012
Location: North Carolina
Posts: 161
Default Re: need help starter/ generator problems

I posted another thread and learned that these are not worn out ...so I guess my hope now lies in the cables being bad they are in pretty bad shape what direction should I look toward if its not the cables. Whats the best way to check the solenoid? I clewned the copper contacts??? Not sure what its called but it had a thick shiny film on it that came off with scotch brite the bearings seem fine so I guess I will put it back together and wait on the wire and ends I ordered because I couldnt find any pre made cables. I have a chance to clean all the connections on starter too
Dmontgomery is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Starter/generator Problems Gas EZGO
88 ezgo gas starter/generator stuck in starter mode Gas EZGO
starter/generator G1 Gas Yamaha
Starter Generator Getting Hot Gas Yamaha
starter generator ???txt Gas EZGO


All times are GMT -5. The time now is 04:12 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.