lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-22-2022, 01:46 PM   #1
Nick G
Not Yet Wild
Star
 
Join Date: Jul 2021
Location: Wildwood New Jersey
Posts: 3
Default 2013 Star No speed stops running

2013 Star Golf Cart. Batteries fully charged and tested. Cart will only go about 8MPH. It runs then stops, have to turn off and keep playing with accelerator pedal to get it to move. Replaced speed sensor. Looking for some clues before I take it to the shop.
Nick G is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Thread Tools
Display Modes


Similar Threads
Thread Forum
wiring harness help needed! 2013 star basket case Star and Fairplay
2010 precedent stops running at speed Electric Club Car
Star cart motor stops Star and Fairplay
1988 ez-go gets up to speed then stops running Gas EZGO
2013 Star 36V golf cart. To buy or not to buy Star and Fairplay


All times are GMT -5. The time now is 04:25 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.