lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 11-09-2017, 12:38 AM   #1
edward karow
Not Yet Wild
 
Join Date: Oct 2013
Posts: 4
Default new batteries no power

hello,
i just got a 93 ez go marathon. i replaced the batteries and the solenoid clicks and it tries to move but acts like the batteries are dead.
i jacked up the rear end and the tires spun when there was no load. how can i tell if the motor is going bad?

thanks,
edward karow is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 11-09-2017, 12:56 AM   #2
yamahaguy97
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 1,067
Default Re: new batteries no power

Well itís probably not the motor. Usually when it runs in the air but not under load it could mean bad batteries but you have new ones. There seems to be lots of resistance somewhere. Check your f/r switch too make sure itís ok
yamahaguy97 is offline   Reply With Quote
Old 11-09-2017, 08:44 AM   #3
Sir Nuke
Master of All Things
 
Sir Nuke's Avatar
E-Z-GO
 
Join Date: May 2013
Location: West Columbia, Texas
Posts: 14,670
Default Re: new batteries no power

when it does that.....with the cart on the ground.....does it sound like the motor is running but just not going anywhere? if so, look at the drivers side axel nut and see if it is spinning when you attempt to make the cart move. if it does, that's your problem, the hub is stripped. its a fairly common ezgo problem.
Sir Nuke is offline   Reply With Quote
Old 11-09-2017, 10:55 AM   #4
EZHO
Gone Wild
 
EZHO's Avatar
E-Z-GO
 
Join Date: Oct 2017
Location: San Diego Ca.
Posts: 289
Default Re: new batteries no power

Quote:
Originally Posted by edward karow View Post
hello,
i just got a 93 ez go marathon. / / / i replaced the batteries

thanks,

Just bought one myself , Same problem , and it was wired wrong, so just another possibility . 36volt right ?

. if you replaced the batteries double check your cables
sorry if thats a dumb answer, but we dont know your skill level and if this is your first cart ?

I'm a newbie myself but good place to start if you just bought it.

Then these guys will help track it down for ya,
.
Heres a Manuel for ya ,if you dont have one yet
.
https://cdnmedia.endeavorsuite.com/i...o%20pdf/58.pdf
.
Oh Ya .......... Welcome to you first post
.
.
Attached Images
File Type: jpg Wiring.jpg (111.1 KB, 0 views)
File Type: jpg Wiring Solid_State.jpg (214.5 KB, 0 views)
File Type: jpg EZGO thru 94'.jpg (7.3 KB, 0 views)
EZHO is offline   Reply With Quote
Old 11-14-2017, 08:37 PM   #5
edward karow
Not Yet Wild
 
Join Date: Oct 2013
Posts: 4
Default Re: new batteries no power

thanks everyone for the advise and downloadable manuals.
i borrowed the service manual i needed from the local golf course, went through the whole trouble shooting process and still found nothing wrong.
i took the forward\reverse switch off and cleaned it, also the axle is not spinning in the hub.
would worn brushes in the motor cause this symptom?
thanks again
edward karow is offline   Reply With Quote
Old 11-15-2017, 08:20 AM   #6
mutant
Gone Wild
E-Z-GO
 
Join Date: Aug 2014
Location: fletcher,nc
Posts: 601
Default Re: new batteries no power

what is the total pack voltage? what is the pack voltage under acceleration? just because they are new dosent mean they are charged...
mutant is offline   Reply With Quote
Old 11-15-2017, 08:57 AM   #7
edward karow
Not Yet Wild
 
Join Date: Oct 2013
Posts: 4
Default Re: new batteries no power

the voltage is 41v across the pack
edward karow is offline   Reply With Quote
Old 11-15-2017, 04:49 PM   #8
edward karow
Not Yet Wild
 
Join Date: Oct 2013
Posts: 4
Default Re: new batteries no power

replaced control unit. all is well. thanks again
edward karow is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
04 TXT No Power/New Batteries Electric EZGO
98 TXT has no power with new batteries Electric EZGO
New batteries and now no power Electric EZGO
New batteries and little power Electric Club Car
98 txt no power new batteries Electric EZGO


All times are GMT -5. The time now is 03:13 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.