lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Columbia ParCar


Post New Thread  Reply
 
Thread Tools Display Modes
Old 03-22-2024, 06:07 AM   #1
Loganj
Not Yet Wild
 
Join Date: Mar 2024
Posts: 3
Default 2010 Parcar - very low torque

Bought this machine for my electrician to use at work. It is 48v and has a new set of 6v batteries. I installed a new Lester charger which appears to have solved its charging issues. It's slow and the speed control switch does nothing so I assumed the speed sensor was bad. When I went to load it up this morning, it wouldn't climb the trailer ramp without getting a little bit of a run at it. Shouldn't it have more torque than that? My Yamaha cart will pull up onto the same trailer easily. It drives around on flat ground ok. Thoughts on what to look at first?
Loganj is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 03-24-2024, 09:01 AM   #2
Tech Support
How Can I Help?
 
Tech Support's Avatar
 
Join Date: Oct 2009
Location: SW Wisc & West Central, FL
Posts: 1,385
Default Re: 2010 Parcar - very low torque

YES! It can pull the weight of an F150 up a loading ramp. My guess is the accelerator cable is so stretched that you might be pressing the pedal down 100% but the controller is getting less than a 50% pedal push signal. You would need to replace the cable between the pedal and the LAD (Linear Accelerator Device). In the meantime you can adjust it. Under the hood is the LAD. At the back side of the LAD, loosen the two nuts of the cable and adjust the cable so it has more pull. That will buy you some time. But be aware it will cause the cable to break soon as it's already on it's last leg so get a cable ordered so you don't get stranded.

Here's the how-to on the cable adjustment. https://evtechnicalservices.com/blog...rt-too-slow-47
Tech Support is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Columbia ParCar


Thread Tools
Display Modes


Similar Threads
Thread Forum
2010 parcar Columbia ParCar
Rear seat for 2010 electric ParCar Columbia ParCar
2010 ParCar will not switch to fast mode Columbia ParCar
2010 ParCar 4 flashes Columbia ParCar
2010 parcar smt4-tn Columbia ParCar


All times are GMT -5. The time now is 02:14 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.