lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-06-2012, 11:49 PM   #1
hillcountrymac
Not Yet Wild
 
Join Date: Jan 2012
Posts: 56
Default Something new?Has anyone heard of this?

Well ya'll know I've had a backfire issue.I kept going over what I could do before ordering a new carb.It was just so close.I checked the screw I used to plug the hole in the intake for the oil injection(again) to make sure it was sealed.Sealed okay,but I had used a screw that was an 1 1/4" long.I pulled it and the threads were wet with fuel mix.I thought about how it was extending into the intake tube and could that make a difference?I went to Ace Hardware and bought a short screw and replaced it.All things the same rubber washer and all,just a much shorter screw.The occasional backfire has stopped.I have waited a while to see if it would rear it's ugly head,but so far so good.Anyone ever heard of this?I don't know why it would work but it seems to have.
hillcountrymac is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 04:31 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.