lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-07-2020, 06:17 PM   #1
bowtieracin
Gone Wild
 
Join Date: May 2009
Posts: 377
Default G8 ignitor issue?

I just got a g8 gas the previous owner says the ignitor is goin bad it will fire up and run but itís pretty doggy. Seems ok in neutral. Heís cleaned carb all that. He said when it quit they messed with the plug on the ignitor and it took off been that way for a couple months now itís most of the time. Thanks
bowtieracin is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Ignitor bad Gas EZGO
G2 to a G9 ignitor Gas Yamaha
No Ignitor??? Gas Club Car
Possible Ignitor Issue? Gas EZGO
WTB G-9 Ignitor Golf Carts and Parts


All times are GMT -5. The time now is 01:31 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.