lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-21-2018, 09:55 PM   #1
Canuck2400
Getting Wild
E-Z-GO
 
Join Date: Jun 2018
Location: Ontario Canada
Posts: 122
Default Still not working

I thought I had someone lined to look at cart, but he's too busy along with a few other mechanics I called--- the cart works in reverse, but not forward-- is there anything besides the (rocker) switch I should be looking at. Thanks for any recommendations.
Canuck2400 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-21-2018, 09:58 PM   #2
Canuck2400
Getting Wild
E-Z-GO
 
Join Date: Jun 2018
Location: Ontario Canada
Posts: 122
Default Re: Still not working

I forgot to mention it is an 07 EZGO PDS 36v
Canuck2400 is offline   Reply With Quote
Old 06-22-2018, 09:03 AM   #3
mgray70
Gone Wild
 
mgray70's Avatar
E-Z-GO
 
Join Date: Apr 2013
Location: Deep Run, NC
Posts: 2,033
Default Re: Still not working

If the switch checks ok, that usually means one side out the controller has failed. Switch the f1 and f2 wires at the controller and see if the problem reverses. If it does your controller is bad.

Sent from my SM-G930R4 using Tapatalk
mgray70 is offline   Reply With Quote
Old 06-22-2018, 12:31 PM   #4
Canuck2400
Getting Wild
E-Z-GO
 
Join Date: Jun 2018
Location: Ontario Canada
Posts: 122
Default Re: Still not working

Thank you I'll try that this afternoon
Canuck2400 is offline   Reply With Quote
Old 06-22-2018, 01:17 PM   #5
Canuck2400
Getting Wild
E-Z-GO
 
Join Date: Jun 2018
Location: Ontario Canada
Posts: 122
Default Re: Still not working

I just reversed the cables , now it only goes forward--- so much for the brand new controller--- will it hurt to leave it wired the way it is and use the cart until I get a new controller?--- thanks again for the help
Canuck2400 is offline   Reply With Quote
Old 06-22-2018, 04:08 PM   #6
mgray70
Gone Wild
 
mgray70's Avatar
E-Z-GO
 
Join Date: Apr 2013
Location: Deep Run, NC
Posts: 2,033
Default Re: Still not working

Quote:
Originally Posted by Canuck2400 View Post
I just reversed the cables , now it only goes forward--- so much for the brand new controller--- will it hurt to leave it wired the way it is and use the cart until I get a new controller?--- thanks again for the help
It will not hurt to run it that way. If its new what kind of controller is it? Should have some warranty on it?

Sent from my SM-G930R4 using Tapatalk
mgray70 is offline   Reply With Quote
Old 06-22-2018, 06:09 PM   #7
Canuck2400
Getting Wild
E-Z-GO
 
Join Date: Jun 2018
Location: Ontario Canada
Posts: 122
Default Re: Still not working

I'm going to contact them --- it's a Curtis 1206 mx
Canuck2400 is offline   Reply With Quote
Old 06-22-2018, 08:21 PM   #8
mgray70
Gone Wild
 
mgray70's Avatar
E-Z-GO
 
Join Date: Apr 2013
Location: Deep Run, NC
Posts: 2,033
Default Re: Still not working

Was it new, or rebuilt? If I had to guess I bet it was a rebuilt one. Even so it should have a one year warranty. Get your money back and get you an Alltrax XCT.
Quote:
Originally Posted by Canuck2400 View Post
I'm going to contact them --- it's a Curtis 1206 mx
Sent from my SM-G930R4 using Tapatalk
mgray70 is offline   Reply With Quote
Old 06-23-2018, 01:14 PM   #9
Canuck2400
Getting Wild
E-Z-GO
 
Join Date: Jun 2018
Location: Ontario Canada
Posts: 122
Default Re: Still not working

It was brand new --- I'll look into the Alltrax-- thanks again for your help
Canuck2400 is offline   Reply With Quote
Old 07-07-2018, 02:37 PM   #10
Canuck2400
Getting Wild
E-Z-GO
 
Join Date: Jun 2018
Location: Ontario Canada
Posts: 122
Default Re: Still not working

Still having problems, I installed a new controller (haven't got the Alltrax yet) , but got a deal on a rebuilt Curtis, so I changed it, and it's doing the same thing--- reverse but no forward, switched the 2 wires in controller and it runs in forward but no reverse, the only part I haven't changed is the reverse buzzer, would that cause the problem ???---/ thanks
Canuck2400 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
My Trail Hog just stopped working, and then started working again. Electric EZGO
Working on G2 Gas Yamaha
Battery Charger Not Working - Cart Not Working Electric EZGO
Need Help 96 DCS not working Electric EZGO
WTB non working TXT gas Golf Carts and Parts


All times are GMT -5. The time now is 04:23 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.