lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 09-08-2012, 06:26 PM   #1
Dewey
Not Yet Wild
 
Join Date: Jun 2009
Posts: 20
Default Cart Runs But Dies Quickly

I have a club car with fairly new batteries. It worked great until last week. Here is what happens. I put it in forward and will take off and go about a hundred yards and then become sluggish with no hill climbing power. It also will not not go in reverse. There is a coil on a solenoid that becomes very hot when this happens. I need to mention that I have checked my wires an none are loose and have tested my batteries and they are good. If I wait a while I can do the same all over again with out charging it. This cart is my wife' baby so I need to get it going. PLEASE HELP A BROTHER OUT. Thanks.
Dewey is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Par car runs, then dies Gas Columbia ParCar
86 2pg runs then dies Gas EZGO
EZGO Runs Than Dies!!!!! Gas EZGO
48V cart dies, then after sitting a while runs again? Electric Club Car
86 Parcar runs and dies, runs and dies Gas Columbia ParCar


All times are GMT -5. The time now is 03:51 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.