lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-23-2009, 03:42 PM   #1
chucksezgoj402
Not Yet Wild
 
Join Date: Jun 2009
Posts: 2
Cool EZGO J402 motor runs but cart won't move

I am having a problem with my EZGO J402. I checked the batteries - OK 37.6 volts, wiring OK, drive motor runs, but cart won't move. Any suggestions?????
chucksezgoj402 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-23-2009, 04:00 PM   #2
pggroves
steeplejack x
 
pggroves's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Republic of Texas
Posts: 3,382
Default Re: EZGO J402 motor runs but cart won't move

Pull the dust cover on the hubs and see if the axle nut turns when motor runs. If yes = stripped hub (aka brake drum)
Also, if that battery voltage is after a full charge, you probably have battery issues as well. One bad one can stop that era cart. Is it a PDS?
pggroves is offline   Reply With Quote
Old 06-24-2009, 10:08 AM   #3
chucksezgoj402
Not Yet Wild
 
Join Date: Jun 2009
Posts: 2
Default Re: EZGO J402 motor runs but cart won't move

Hey,Thanks for the info , pulled the right rear wheel and found it spinning on the output
shaft. Thanks again.

Chuck
chucksezgoj402 is offline   Reply With Quote
Old 06-24-2009, 12:00 PM   #4
pggroves
steeplejack x
 
pggroves's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Republic of Texas
Posts: 3,382
Default Re: EZGO J402 motor runs but cart won't move

When you replace the hub, tighten the castle nut "tighter than gornoman in spandex" and then tighter to align for cotter pin. DO NOT BACK OFF. I think the spec is 90 ft lbs, but I routinely put more than that on them.
pggroves is offline   Reply With Quote
Old 06-25-2009, 06:32 AM   #5
gornoman
Stay thirsty my friends!
 
gornoman's Avatar
Mixed Breed
 
Join Date: Jan 2007
Location: Suburban Chicago
Posts: 24,206
Default Re: EZGO J402 motor runs but cart won't move

Quote:
Originally Posted by pggroves View Post
When you replace the hub, tighten the castle nut "tighter than gornoman in spandex" and then tighter to align for cotter pin. DO NOT BACK OFF. I think the spec is 90 ft lbs, but I routinely put more than that on them.
Some days I feel like Rodney Dangerfield, no respect!
gornoman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZGO DCS Cart won't Move Electric EZGO
97 Ezgo Motor runs but will not move Gas EZGO
Motor runs after I pressed the brake and a short backfire. Gas EZGO
Club Car Complete Motor - Runs Golf Carts and Parts
1985 Electric EZ-Go motor runs in Fwd/REV Electric EZGO


All times are GMT -5. The time now is 06:23 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.