lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 05-06-2010, 07:07 PM   #1
dlh133
Not Yet Wild
 
Join Date: Mar 2010
Posts: 15
Default total charge IV only charging for an hour??

New to golf carting and loving it. I have a 2000 ezgo series cart, everything is stock. I did just put all 4ga. wires and just put in new workaholics batteries, not by choice but they where $300 and t105 in my area are $600. anyhow my problem is my charger ,Total charge IV with the led timer, is only charging for about an hour and a half then stops charging. I dont have a volt meter or anything to test with. I did just change out the circut board b/c the charger wasn't working at all. even with the old t605 batteries the where in the cart the charger still only charged for about an hour and half. So just wondering if anyone could tell me why this is?? New batts are supposed to come with 70% charge right? wouldn't it take longer than hour to get it fully charged?? Thanks!
dlh133 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 05-07-2010, 07:25 AM   #2
dlh133
Not Yet Wild
 
Join Date: Mar 2010
Posts: 15
Default Re: total charge IV only charging for an hour??

not sure if i was supposed to but i tried to charge my new batts again and my charger shut off after 30mins. i did it again and 30mins more and shut off.

i want to break-in the batts the right way but this doesn't seem right. Is it possible for the new batts to fully charged with a total of 2 hour charge?
dlh133 is offline   Reply With Quote
Old 05-07-2010, 10:39 AM   #3
gornoman
Stay thirsty my friends!
 
gornoman's Avatar
Mixed Breed
 
Join Date: Jan 2007
Location: Suburban Chicago
Posts: 24,205
Default Re: total charge IV only charging for an hour??

dlh133, Welcome to BGW!

Without a digital volt meter there is no telling just what the heck is going on. Get a meter, it is a necessary tool for a sparky owner. No need to spend more than $25 for one, and they are easy to learn.
gornoman is offline   Reply With Quote
Old 05-07-2010, 05:42 PM   #4
dlh133
Not Yet Wild
 
Join Date: Mar 2010
Posts: 15
Default Re: total charge IV only charging for an hour??

I got a multimeter today and tested my new batts.

1-6.38
2-6.38
3-6.37
4-6.37
5-6.37
6-6.37
total=38.2

i guess this are good numbers. so i'm going to run it for 20mins and recharge and see if i can get a longer charge time then an hour and a half. I hope this is the right way to break the batts in.
dlh133 is offline   Reply With Quote
Old 05-07-2010, 07:38 PM   #5
pggroves
steeplejack x
 
pggroves's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Republic of Texas
Posts: 3,382
Default Re: total charge IV only charging for an hour??

http://www.buggiesgonewild.com/elect...one-right.html
pggroves is offline   Reply With Quote
Old 05-07-2010, 09:35 PM   #6
dlh133
Not Yet Wild
 
Join Date: Mar 2010
Posts: 15
Default Re: total charge IV only charging for an hour??

i have read over the battery break-in and everything leads me to think that the batts should be charging for around 5 to 12 hours is this right?

i drove my cart for 23mins. then put it on the charger and again it only charged for 48mins. then shut off. my total pack is at 38.5 now, before the charge "after my 23min ride" the pack read 37.1

does this mean my charger is charging to fast or that i just didn't draw enough out of the batts in 23mins.?
dlh133 is offline   Reply With Quote
Old 05-07-2010, 10:32 PM   #7
pggroves
steeplejack x
 
pggroves's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Republic of Texas
Posts: 3,382
Default Re: total charge IV only charging for an hour??

Sorry, I'm just not familiar with that charger. Your pack is 100% charged at 38.5v. Was the 23 minutes actual pedal time? Meaning the accelerator was engaged for 23 minutes providing power to the system? I agree, usually a full charge cycle takes much longer and there may be a timer issue with the charger.
pggroves is offline   Reply With Quote
Old 05-07-2010, 10:41 PM   #8
dlh133
Not Yet Wild
 
Join Date: Mar 2010
Posts: 15
Default Re: total charge IV only charging for an hour??

yes, for 23mins the pedal was down.

its strange, i think i'm the only one that has this charger. i can not find anything when i search this site or even google.

even with my old batts that were ran down to low voltage still the charger ran for a hour and a half then batts were fully charged. I don't get it.

will charging that fast damage my new batts?
dlh133 is offline   Reply With Quote
Old 05-08-2010, 08:41 AM   #9
pggroves
steeplejack x
 
pggroves's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Republic of Texas
Posts: 3,382
Default Re: total charge IV only charging for an hour??

If you can, try another charger on your cart and also try your charger on another cart. Also, if you have a 6v or 12v charger charge your batteries individually or in pairs and then check the voltage on each and the pack again after you're done.
pggroves is offline   Reply With Quote
Old 05-08-2010, 08:11 PM   #10
dlh133
Not Yet Wild
 
Join Date: Mar 2010
Posts: 15
Default Re: total charge IV only charging for an hour??

Well i drove the cart with the pedal down for 20mins, the cart is superisingly fast its got to be doing 19 to 20mph. At the end of my ride the cart had no more pedal and started smoking under the controller cover, I pulled the cover and the brand new solenoid was so hot I couldn't touch it. And it smells burnt bad. What could make it burn up?

I did put it on charge after this and it charged again for 48mins.

something definitly not right with my set up either the controller is bad, the f/r, solenoid, charger, what else is there. the motor can't be bad and the batts are brand new with a good reading. so what gives?
dlh133 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Total Charge I - AC connections Electric EZGO
EZGO 26984 Total Charge III NEW PROBLEM Electric EZGO
Ez Go Total Charge 3 Charger Golf Carts and Parts
"91 total charge diode Electric EZGO
Looking for Total Charge III Golf Carts and Parts


All times are GMT -5. The time now is 08:59 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.