lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-14-2008, 12:40 PM   #1
wizard
Not Yet Wild
 
Join Date: Aug 2008
Posts: 5
Default starting problem with 1989 EZGO 2-cycle

Hi, all. New here, and with a problem I have a 1989 EZGO with 2 cycle Robins....sat all winter, started up fine this spring. A month later, it would not start. It tries but seems to fire only every 10 revolutions or so. I have checked the filters, drained the carb, replaced the spark plug. Comp seems ok, but may be low. Any ideas, or should I just tote it off to a shop?
wizard is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
problem with starting a 91 clubcar Gas Club Car
1989 ezgo robins EC25 engine Gas EZGO
Starting problem Gas Yamaha
Hard Starting 1989 2 Stroke Gas EZGO
1981 G1 Starting Problem Gas Yamaha


All times are GMT -5. The time now is 10:51 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.