lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-30-2016, 08:09 AM   #11
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 72,964
Default Re: EZGO stopped abruptly 1 mile from starting

Okay - 36v rocker on the dash is a PDS drive system. I assume the solenoid does not click when you try to go with key on, cart in gear.

Attached is the solenoid activation circuit. Power for the key switch started at the charge receptacle in the early years and at the battery pack main (+) in the later yrs.

Other wise the yrs are the same. You should have 36v (+) at each end of every red line on this diagram. Using your voltmeter, start at the beginning and tell us where the power stops.
Attached Images
File Type: jpg Ezgo PDS solenoid activation diagram.jpg (148.6 KB, 0 views)
scottyb is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-30-2016, 08:57 AM   #12
Dog Hunter
Not Yet Wild
 
Join Date: Sep 2016
Posts: 24
Default Re: EZGO stopped abruptly 1 mile from starting

Solenoid does click when pedal is pushed. Also getting 36.7 volts to motor when pedal is pushed.
Dog Hunter is offline   Reply With Quote
Old 09-30-2016, 09:26 AM   #13
birddog5
Getting Wild
E-Z-GO
 
Join Date: May 2013
Location: Northern MN
Posts: 79
Default Re: EZGO stopped abruptly 1 mile from starting

this sounds a lot like my issue too - might piggy back on this post -

Same deal - drove to golf course, by hole two - cart just stops - towed it home - filled batteries with DI water - charged - made full round and died in the parking lot after 9 holes. checked batteries - all read 6.3 except one battery that read 6.0 - is it as easy as one dead battery?
birddog5 is offline   Reply With Quote
Old 09-30-2016, 09:29 AM   #14
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 72,964
Default Re: EZGO stopped abruptly 1 mile from starting

Tug and twist each end of all 10 high amp cables.

Put th voltmeter leads on controller B- and M- in any order. Have somebody depress the go pedal until the solenoid clicks, the meter should show full pack voltage. Now slowly push the pedal to the floor as you watch the meter, the reading should go to near 0 volts.
scottyb is offline   Reply With Quote
Old 10-01-2016, 05:18 PM   #15
Dog Hunter
Not Yet Wild
 
Join Date: Sep 2016
Posts: 24
Default Re: EZGO stopped abruptly 1 mile from starting

Which post is M-???
Dog Hunter is offline   Reply With Quote
Old 10-01-2016, 05:47 PM   #16
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 72,964
Default Re: EZGO stopped abruptly 1 mile from starting

Sorry, I meant B- and A1
scottyb is offline   Reply With Quote
Old 10-01-2016, 06:20 PM   #17
Dog Hunter
Not Yet Wild
 
Join Date: Sep 2016
Posts: 24
Default Re: EZGO stopped abruptly 1 mile from starting

Ok initial reading was 7.5 volts. I just took it off of charge. Pressed pedal until solenoid clicked volts read 1.5. Slowly pressed pedal and volts dropped to 0 then went to 7.5 when pressed all the way to floor.
Dog Hunter is offline   Reply With Quote
Old 10-02-2016, 07:42 AM   #18
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 72,964
Default Re: EZGO stopped abruptly 1 mile from starting

Screwy results. Put a fresh battery in your meter and post pics of the electronics in the cart. NOT closeups, we got zoom. We want to see how everything is tied together. Maybe something glaringly wrong.

Have you twisted and tugged on all high amp cable ends...Are all connections clean? post some pics.
scottyb is offline   Reply With Quote
Old 10-04-2016, 06:32 PM   #19
Dog Hunter
Not Yet Wild
 
Join Date: Sep 2016
Posts: 24
Default Re: EZGO stopped abruptly 1 mile from starting

Here is a pic!!

Dog Hunter is offline   Reply With Quote
Old 10-04-2016, 06:59 PM   #20
Dog Hunter
Not Yet Wild
 
Join Date: Sep 2016
Posts: 24
Default Re: EZGO stopped abruptly 1 mile from starting

Pic with volt meter on as instructed

Dog Hunter is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2002 CC DS Stopped abruptly in Fwd, Charge indicator displays no charge Electric Club Car
EZGO hybrid - 150 mile range Electric EZGO
23 hp upgrade less then 5 mile Golf Carts and Parts
Yamaha electric cart stopped abruptly; will not start; no click from solenoid. Electric Yamaha


All times are GMT -5. The time now is 10:04 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.