lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 10-06-2016, 06:20 PM   #21
Dog Hunter
Not Yet Wild
 
Join Date: Sep 2016
Posts: 24
Default Re: EZGO stopped abruptly 1 mile from starting

TTT... Come on guys I need some help!
Dog Hunter is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 10-08-2016, 08:16 PM   #22
Dog Hunter
Not Yet Wild
 
Join Date: Sep 2016
Posts: 24
Default Re: EZGO stopped abruptly 1 mile from starting

What voltage should I have at B- and A1 when solenoid clicks??
Dog Hunter is offline   Reply With Quote
Old 10-11-2016, 10:02 AM   #23
Dog Hunter
Not Yet Wild
 
Join Date: Sep 2016
Posts: 24
Default Re: EZGO stopped abruptly 1 mile from starting

All wires are tight guys. I added pictures in previous post. Any help is greatly appreciated. Still curious as to how may volts I should get at controller when solenoid engages.
Dog Hunter is offline   Reply With Quote
Old 10-11-2016, 10:07 AM   #24
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 72,965
Default Re: EZGO stopped abruptly 1 mile from starting

With the solenoid precharge resistor removed, the reading between B+ and B- should be 0v and when the solenoid clicks it should be pack voltage (36 or 48v plus) When the solenoid clicks the reading between A1 and B- shoud be the same and this reading should go down as the go pedal is depressed. - if not - check the throttle input signal and controller circuit board power (pin 1 ? depends upon which control you are working with)

Thanks for the pic - it appears the environmental cover has not been in place for some time. This control cannot survive such exposure. SO the prognosis is not good for it.
scottyb is online now   Reply With Quote
Old 10-11-2016, 08:47 PM   #25
Dog Hunter
Not Yet Wild
 
Join Date: Sep 2016
Posts: 24
Default Re: EZGO stopped abruptly 1 mile from starting

Ok. Thanks I will check it one evening this week. I've had the cart for 5 years and the first time I ever removed the cover was when this issue started the first of this month. So I will add a silicone gasket to the cover once I get it going again.
Dog Hunter is offline   Reply With Quote
Old 10-23-2016, 02:20 PM   #26
Dog Hunter
Not Yet Wild
 
Join Date: Sep 2016
Posts: 24
Default Re: EZGO stopped abruptly 1 mile from starting

Here is an update!!!! I just checked my motor. I disconnected all wires from motor. Put a jumper from A1 to F1 then a jumper from A2 to F2. Attached positive cable to A2/F2 and negative to A1/F1. Attached the other end of the cables to my Toyota truck battery. The golf cart wheels did not turn. I turned them with my hand to give them a start and they would stop spinning after a few rotations. The connection was good from the truck battery to the golf cart motor. So my question is there any other test needed to verify that my golf cart motor needs replacing??
Dog Hunter is offline   Reply With Quote
Old 10-24-2016, 07:53 PM   #27
Dog Hunter
Not Yet Wild
 
Join Date: Sep 2016
Posts: 24
Default Re: EZGO stopped abruptly 1 mile from starting

Ttt. Contemplating having my controller rebuilt to 400 amps and buying a new EZGO PDS/DCS High speed motor. From everything I've read this motor and the controller upgrade would be sufficient for my 36 volt system. And would still be okay when or if I ever upgraded to a 48 volt system. I would just need to upgrade the wiring when I decided to go to 48 volts. Plus the new batteries of course. So Am I right with this assumption or am I missing something??? I've done a lot of amateur research and am asking for expert advice.
Dog Hunter is offline   Reply With Quote
Old 10-25-2016, 07:35 AM   #28
timmyjane
Gone Wild
 
timmyjane's Avatar
E-Z-GO
 
Join Date: Jul 2015
Location: Simpsonville, SC
Posts: 245
Default Re: EZGO stopped abruptly 1 mile from starting

What kind of motor is it? GE AMD? Could Plum Quick possibly make a repair to your motor?
timmyjane is offline   Reply With Quote
Old 10-25-2016, 11:51 AM   #29
mutant
Gone Wild
E-Z-GO
 
Join Date: Aug 2014
Location: fletcher,nc
Posts: 601
Default Re: EZGO stopped abruptly 1 mile from starting

controllers cannot be rebuilt,only repaired...you get what you pay for IF you are lucky...i see a lot of failed "rebuilt"controllers on here....
mutant is offline   Reply With Quote
Old 10-25-2016, 08:04 PM   #30
Dog Hunter
Not Yet Wild
 
Join Date: Sep 2016
Posts: 24
Default Re: EZGO stopped abruptly 1 mile from starting

Motor is an Advanced motor and Driver... AU2500 FLT SPD 04/23/07... Part # DE2-4007....36 volt
Dog Hunter is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2002 CC DS Stopped abruptly in Fwd, Charge indicator displays no charge Electric Club Car
EZGO hybrid - 150 mile range Electric EZGO
23 hp upgrade less then 5 mile Golf Carts and Parts
Yamaha electric cart stopped abruptly; will not start; no click from solenoid. Electric Yamaha


All times are GMT -5. The time now is 10:31 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.