lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-29-2009, 08:28 PM   #1
cutdown
Not Yet Wild
 
Join Date: Jun 2009
Posts: 2
Default old 3 wheel ezgo trouble

Today I picked up an e z go three wheel cart. I can not read the numbers on the tag so i do not know what year or model, but, I hope someone can help. I do know that it is a 2 stroke and was probably made in the 80s.

When I picked it up the man did show me that the engine ran but it did not have a "drive belt" so it would not move. So on my way home I stopped at a shop and picked one up. He also told me that the brakes were shot.

Now I have put the belt on, the engine starts right up the belt spins the pulley and not much happens. That cart will budge and might roll a foot but thats it.

I put it on jack stands and pressed the gas and nothing happens. The driver side has some grinding and clunking when i turn the wheel by hand. I can not get the hub off to look at the brakes or to find out where the sound it coming from .

I do not have much into this cart and kinda want to keep it that way, so I do not want to take it into a shop to have them look it over. Any tips or help would be greatly appreciated!

thank you for you time.
cutdown is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-29-2009, 08:33 PM   #2
scottyb
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 70,635
Default Re: old 3 wheel ezgo trouble

It may be that the hub is striped out in the passenger side brake drum .....
scottyb is offline   Reply With Quote
Old 06-29-2009, 09:28 PM   #3
ruredy
Born Wild
 
ruredy's Avatar
 
Join Date: Mar 2007
Location: Clover SC.
Posts: 5,552
Default Re: old 3 wheel ezgo trouble

Quote:
Originally Posted by scottyb View Post
It may be that the hub is striped out in the passenger side brake drum .....

take the dust caps off the drum and see if the nut is spinning when trying to go. If so then it's a stripped hub
ruredy is offline   Reply With Quote
Old 06-30-2009, 12:04 PM   #4
cutdown
Not Yet Wild
 
Join Date: Jun 2009
Posts: 2
Default Re: old 3 wheel ezgo trouble

thanks for the tips....i will check that as soon as i get home
cutdown is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
89 ezgo spark trouble Gas EZGO
trouble shooting ezgo elect. '93' marathon Electric EZGO
trouble shooting ezgo elect. '93' marathon Electric EZGO
Trouble shooting with my ezgo! Gas EZGO
3 wheel ezgo wiring trouble Electric EZGO


All times are GMT -5. The time now is 02:47 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.