lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-04-2012, 07:14 PM   #1
Flippz
Not Yet Wild
 
Join Date: Nov 2012
Posts: 53
Default Spark plug boot problem

I have a 96 g16a and I love it. It has a 6" lift and itp wheels and tires. When driving over rough terrain and hilly areas the wire will pull loose from the boot for the spark plug. Does anyone else have this issue. Also what's the proper fix? I don't want to tape it and stretch the wire I also am tired of getting out to fix the boot when I am enjoying a leisure ride with an adult beverage.
One other thing how can I tell if the better spring has been installed for the clutch. Mine is white. I wish I could post pics but all I have is an iPad. The cart has been built nicely using quality stuff and seems to quick but I don't want to spend the money on that if it all ready has it.

Scott Ross
Thanks.
Flippz is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
1980s Cart Spark plug problem Gas EZGO
Spark Plug Problem Gas EZGO
Spark plug gap Gas EZGO
g1 spark plug Gas Yamaha
G1 spark plug Gas Yamaha


All times are GMT -5. The time now is 04:22 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.