lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 12-12-2010, 05:10 PM   #1
mikeevans860
Gone Wild
 
mikeevans860's Avatar
E-Z-GO
 
Join Date: Nov 2010
Location: Corona California
Posts: 168
Default lifted my cart today and not I am getting a weird noise and grinding sound

I dont know what happened but now that I lifted the cart when I start going fast there is a loud noise coming from the passenger wheel. Could my rear end be going out? Could it have anything to do with the lift?
mikeevans860 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 12-12-2010, 05:28 PM   #2
littlebob
Getting Wild
Yamaha
 
Join Date: Dec 2010
Location: Baton Rouge, La
Posts: 89
Default Re: lifted my cart today and not I am getting a weird noise and grinding sound

Check the parking brake cable to that wheel. When you lifted it, it might have taken all the freeplay out if it was still attached to the chassis in the same place.
littlebob is offline   Reply With Quote
Old 12-12-2010, 08:35 PM   #3
thewskrs
Gone Wild
E-Z-GO
 
Join Date: Apr 2010
Location: Malakoff, TX
Posts: 381
Default Re: lifted my cart today and not I am getting a weird noise and grinding sound

Check your tire clearances all around. Some lifts cause rubbing unless you put on off set rims.
thewskrs is offline   Reply With Quote
Old 12-13-2010, 01:40 PM   #4
mikeevans860
Gone Wild
 
mikeevans860's Avatar
E-Z-GO
 
Join Date: Nov 2010
Location: Corona California
Posts: 168
Default Re: lifted my cart today and not I am getting a weird noise and grinding sound

This problem only starts happening at high speeds
mikeevans860 is offline   Reply With Quote
Old 12-13-2010, 03:18 PM   #5
StoveBolt
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 3,392
Default Re: lifted my cart today and not I am getting a weird noise and grinding sound

I'm with littlebob, brake cable stretched out? on some you have to pull the cable out of the bracket that is right below the battery on the frame. I straiten out the bracket put the cable under it and plastic tie it through the hole.
StoveBolt is offline   Reply With Quote
Old 12-14-2010, 10:23 AM   #6
BrewCityMusic
Hammer Down !!!!
 
BrewCityMusic's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Lake Geneva, WI
Posts: 2,681
Default Re: lifted my cart today and not I am getting a weird noise and grinding sound

it's a longshot, but check your engine mounts - mine were shot but I didn't really notice until I lifted the cart and at higher RPM's the engine was actually making contact with the driven clutch cover (it was moving around THAT much, but at normal angles it wasn't rubbing, with the lift though it was just enough weight distribution to make it do it at speed)
BrewCityMusic is offline   Reply With Quote
Old 12-14-2010, 10:27 AM   #7
mikeevans860
Gone Wild
 
mikeevans860's Avatar
E-Z-GO
 
Join Date: Nov 2010
Location: Corona California
Posts: 168
Default Re: lifted my cart today and not I am getting a weird noise and grinding sound

thats probably it I noticed that my engine mounts are shot.
mikeevans860 is offline   Reply With Quote
Old 12-14-2010, 11:16 AM   #8
Dave Box
Respect the Cart
 
Dave Box's Avatar
E-Z-GO
 
Join Date: May 2010
Location: Rocky Mount, Virginia
Posts: 2,189
Default Re: lifted my cart today and not I am getting a weird noise and grinding sound

BrewCity, you may have girly little fingers but, good lord Dale, you know your way around these 2PGs. Kudos to you man.
Dave Box is offline   Reply With Quote
Old 01-10-2011, 02:16 PM   #9
mikeevans860
Gone Wild
 
mikeevans860's Avatar
E-Z-GO
 
Join Date: Nov 2010
Location: Corona California
Posts: 168
Default Re: lifted my cart today and not I am getting a weird noise and grinding sound

it sounds like some kind of grinding from the rear passenger side. I am going to replace the bearings and see if that helps.
mikeevans860 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Driving my ez Go hit the brakes herd a grinding sound Gas EZGO
2004 Club Car IC making weird sound Electric Club Car
Kind of a Grinding Noise Gas EZGO
Bad rear end E Z Go 3 wheel make grinding sound Electric golf carts
grinding noise from rear Electric Club Car


All times are GMT -5. The time now is 12:01 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.