lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-17-2015, 11:21 AM   #1
richard3529
Getting Wild
 
richard3529's Avatar
E-Z-GO
 
Join Date: Jan 2012
Location: Dothan, Al
Posts: 98
Default 2004 EZ-GO TXT Problem

Good Morning, I have a 2004 TXT, 295 Robins engine. Last year I connected a digital volt meter to the starter/generator. While we were out carting this weekend I developed a problem with performance. Most of the time, when I would start out the volt meter would jump up to 17 or 18 volts and the cart would become very sluggish and run at about 1/2 speed, almost like it was flooding out. The headlights would also get very bright as you would expect. After a while the voltage would drop the the high 12 to low 13 volt range, headlights go normal and the cart would take off. This happened all weekend. The engine could be hot or cold with no pattern, sometimes at start-up and other times during the ride. There was no unusual noise. I checked grounds, belts and connections with no luck. At the high voltage the cart would have almost no torque. I am thinking voltage regulator but at the same time, why the loss of power with the higher voltage to the coil? Any ideas would be greatly appreciated since this engine has been a pain the the butt since I bought the cart.
richard3529 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 02-17-2015, 12:22 PM   #2
jeffrun
Gone Wild
 
Join Date: Apr 2011
Location: Washington State
Posts: 385
Default Re: 2004 EZ-GO TXT Problem

Yes, your voltage regulator is not working right. Voltage should be between 13.5 to 14.5 . With the higher voltage it would over heat coil and ignitior, maybe account for lack of peformance. I would change regulator out and go from there.
jeffrun is offline   Reply With Quote
Old 02-18-2015, 10:55 PM   #3
sccowboy
It ain't gonna be easy.
 
sccowboy's Avatar
E-Z-GO
 
Join Date: Apr 2008
Location: St. George, SC
Posts: 1,471
Default Re: 2004 EZ-GO TXT Problem

Agreed..... V/R. If you grab a service guide from the tech section you will find the trouble shooting guide for the charging system.
sccowboy is offline   Reply With Quote
Old 02-19-2015, 08:58 AM   #4
richard3529
Getting Wild
 
richard3529's Avatar
E-Z-GO
 
Join Date: Jan 2012
Location: Dothan, Al
Posts: 98
Default Re: 2004 EZ-GO TXT Problem

Thanks for the response. A new V/R should be in tomorrow and I will get it installed over the weekend.
richard3529 is offline   Reply With Quote
Old 02-19-2015, 12:30 PM   #5
sccowboy
It ain't gonna be easy.
 
sccowboy's Avatar
E-Z-GO
 
Join Date: Apr 2008
Location: St. George, SC
Posts: 1,471
Default Re: 2004 EZ-GO TXT Problem

I would still go through the trouble shooting process to make sure everything else is good to go.
sccowboy is offline   Reply With Quote
Old 02-19-2015, 03:10 PM   #6
richard3529
Getting Wild
 
richard3529's Avatar
E-Z-GO
 
Join Date: Jan 2012
Location: Dothan, Al
Posts: 98
Default Re: 2004 EZ-GO TXT Problem

Thanks Sccowboy, I've got those pages printed and was going go through the procedure before installing the new V/R.
richard3529 is offline   Reply With Quote
Old 02-19-2015, 06:54 PM   #7
sccowboy
It ain't gonna be easy.
 
sccowboy's Avatar
E-Z-GO
 
Join Date: Apr 2008
Location: St. George, SC
Posts: 1,471
Default Re: 2004 EZ-GO TXT Problem

No worries. Good luck
sccowboy is offline   Reply With Quote
Old 02-21-2015, 05:30 PM   #8
richard3529
Getting Wild
 
richard3529's Avatar
E-Z-GO
 
Join Date: Jan 2012
Location: Dothan, Al
Posts: 98
Default Re: 2004 EZ-GO TXT Problem

Went through the trouble shooting process and the readings pointed to the V/R. Installed the new V/R and went through the test again, all was as it should be. Did a test run and the problem is corrected. Thanks for the feed back.
richard3529 is offline   Reply With Quote
Old 02-21-2015, 10:37 PM   #9
sccowboy
It ain't gonna be easy.
 
sccowboy's Avatar
E-Z-GO
 
Join Date: Apr 2008
Location: St. George, SC
Posts: 1,471
Default Re: 2004 EZ-GO TXT Problem

Congratulations
sccowboy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2004 48V DS problem Electric Club Car
2004 cc charging problem Electric Club Car
2004 IQ 48v charging problem Electric Club Car
2004 ezgo problem Electric EZGO


All times are GMT -5. The time now is 01:21 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.