lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 03-17-2015, 08:11 PM   #1
BGONE
Not Yet Wild
 
Join Date: Oct 2007
Posts: 19
Default 2001 st Workhorse no power

I'm stumped.... I've searched the forum and tried things I've found but no success. When its under any type of load even just flat ground it will hardly pull it's self with slight back fire through carb. But point it down hill or put the rear end on Jack stands it runs great. I've pulled the carb and cleaned, cleaned out pulse tube to fuel pump, replaced fuel filter and all fuel lines. Before I go any farther I want to ask for suggestions. Would spark plugs, or valve adjust cause any of this. This whole thing started over night it ran great when I parked it then a week later it was this. Any help would be greatly appreciated
BGONE is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 03-17-2015, 08:17 PM   #2
sccowboy
It ain't gonna be easy.
 
sccowboy's Avatar
E-Z-GO
 
Join Date: Apr 2008
Location: St. George, SC
Posts: 1,471
Default Re: 2001 st Workhorse no power

Do a valve adjustment and make sure the throttle plate is closing just before the micro switch under the gas pedal cuts off.
sccowboy is offline   Reply With Quote
Old 03-17-2015, 08:23 PM   #3
Mattm
Getting Wild
 
Mattm's Avatar
E-Z-GO
 
Join Date: Aug 2013
Location: North East Georgia
Posts: 108
Default Re: 2001 st Workhorse no power

I agree with cowboy, mine did a similar thing. I adjusted the valves and it worked for me.
Mattm is offline   Reply With Quote
Old 03-17-2015, 08:50 PM   #4
BGONE
Not Yet Wild
 
Join Date: Oct 2007
Posts: 19
Default Re: 2001 st Workhorse no power

I will adjust valves tomorrow and let you know. The plugs were black and wet looking if that means anything
BGONE is offline   Reply With Quote
Old 03-17-2015, 10:29 PM   #5
sccowboy
It ain't gonna be easy.
 
sccowboy's Avatar
E-Z-GO
 
Join Date: Apr 2008
Location: St. George, SC
Posts: 1,471
Default Re: 2001 st Workhorse no power

Possibly a valve issue. Possibly too cold plugs. Or carb float height.
sccowboy is offline   Reply With Quote
Old 03-17-2015, 10:39 PM   #6
sccowboy
It ain't gonna be easy.
 
sccowboy's Avatar
E-Z-GO
 
Join Date: Apr 2008
Location: St. George, SC
Posts: 1,471
Default Re: 2001 st Workhorse no power

Btw, cleaning a carb is subjective. I would get a gallon can of carb cleaner, the one that has the basket and break down the carb. Drop it in over night and blow it all out run a piece of wire thru the jets. Not that you didn't do a good job I'm just throwing it out there.
sccowboy is offline   Reply With Quote
Old 03-18-2015, 05:26 AM   #7
BGONE
Not Yet Wild
 
Join Date: Oct 2007
Posts: 19
Default Re: 2001 st Workhorse no power

I'm going to adjust valves and change plugs. Is there a certain plug that's better than the other? How would I know if it was a float problem? I know it not to full nothing is coming out of the small tubes on the side of the carb. Also is there any type of adjustment on the carb? What's the plastic piece on top that only turns about a quarter turn either way? Thanks again for your help
BGONE is offline   Reply With Quote
Old 03-18-2015, 07:24 AM   #8
kantuckian
Gone Wild
 
Join Date: Dec 2010
Posts: 597
Default Re: 2001 st Workhorse no power

I have a 2002 its has a new rebuilt engine 22'' tires runs great on level ground but chocks down on inclines i have replaced carb/replaced driven clutch/added fresh gas/new plugs/tred 1'' shorter belt/replaced ign coil/replaced fuel pump/absoutly runs and starts perfect but wont even move on the slghtes incline.

Appreciate any suggestions
kantuckian is offline   Reply With Quote
Old 03-18-2015, 08:05 AM   #9
sccowboy
It ain't gonna be easy.
 
sccowboy's Avatar
E-Z-GO
 
Join Date: Apr 2008
Location: St. George, SC
Posts: 1,471
Default Re: 2001 st Workhorse no power

http://products.jacobsen.com/img/manuals/605586.pdf

Go through this manual which contains all the info on plugs, float and carb info. I dropped something on my plastic cap on the carb which broke off its tab.. Officially I believe it's called a low speed idle adjustment. I pulled mine out, cleaned it and screwed it in and backed it oout about 1 1/4 turn.

Kantukian...... Technically, you've hijacked the thread. Copy yours as a new thread and we'll see what we can come up with. Thx
sccowboy is offline   Reply With Quote
Old 04-23-2015, 10:10 PM   #10
BGONE
Not Yet Wild
 
Join Date: Oct 2007
Posts: 19
Default Re: 2001 st Workhorse no power

Sorry for the long delay. Problem is fixed installed New plugs and it's back to running great. I still can't believe that it ran great when I parked it and the plugs just went bad basically over night. Oh well replaced them and now it's all good. Thanks for everyone help
BGONE is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2001 Workhorse Seat Electric EZGO
2001 ez go workhorse st350 Golf Carts and Parts
2001 EZ-Go workhorse won't go... Gas EZGO
2001 Workhorse st-350 Gas EZGO
2001 ez go workhorse Electric EZGO


All times are GMT -5. The time now is 09:30 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.