lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-02-2015, 09:56 AM   #1
danarhorn
Not Yet Wild
 
Join Date: Jul 2014
Posts: 10
Default Cart Won't start + Backfire + Gas Rich

Hey All,

I hope all is going well. Here's the problem. I just had my engine rebuilt on my 92 EZGO TXT, its a 295 cc robin motor. I got the cart back and now it won't start 99% of the time. When it does, it backfires all crazy. I can email a video if you'd like. Apparently its too large to upload. I can also attach pics of whatever is needed. Its got a very gas rich smell, so I'm thinking the throttle plate maybe sticking, though I don't know how to check this. I've adjusted the valves to .004 so that's not the issue. The throttle cables don't seem too far off either. Any thoughts on how to begin to tackle this issue?
danarhorn is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-02-2015, 03:57 PM   #2
danarhorn
Not Yet Wild
 
Join Date: Jul 2014
Posts: 10
Default Re: Cart Won't start + Backfire + Gas Rich

Hey guys,

Update. I pulled the carb off and cleaned it out. Adjusted the screw so the throttle plate closes. It was set so that it never closed. Put it back together, same problem. Still getting some backfire when it does start. It won't stay running when it does start either. If I barely put my foot on the throttle pedal it wants to go, however, once the throttle lever at the carb pushes down and opens up it sounds like its bogging down hard, backfires, and smells really fuel rich. Need help? Remember this is a newly rebuilt motor, with 0.004 valve adjustment, and a freshly cleaned out carb! Taking the air filter off doesn't seem to make a difference either???
danarhorn is offline   Reply With Quote
Reply

Tags
carburetor
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
backfire when getting off cart Gas Yamaha
Cart Running Rich Gas Club Car
Replaced Carb car jerks on initial start then runs rich. Gas Yamaha
'77 cart, top speed and backfire? Gas Harley Davidson
EZ-GO Gas Cart Backfire Gas EZGO


All times are GMT -5. The time now is 08:39 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.