lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-08-2017, 05:51 PM   #1
Duncan10
Not Yet Wild
 
Join Date: May 2017
Posts: 9
Default G2 not charging

Hi everyone hoping someone can give me a couple of pointers to get me going in the right direction. Voltage at the battery before starting is 12.8 or so when starting it drops then when running in neutral it does not increase but then slowly drops. I checked at the red wire on the voltage regulator and it was about 11.5v so then I tried the grounding of the green on the VR and voltage at the battery did increase above the 12.8 or what it was running at. So where do I look or what do I replace next.
Thanks
Duncan
Duncan10 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-08-2017, 06:46 PM   #2
Spicyunicorn
Gone Wild
Yamaha
 
Join Date: Jun 2015
Location: NW Iowa
Posts: 1,669
Default Re: G2 not charging

" then I tried the grounding of the green on the VR " when you grounded the green wire to the battery was the other end connected to the VR? If so you need to ground that wire and the other end must be connected to the starter generator Not the VR and if you're voltage jumps to 17 you have a bad regulator
Spicyunicorn is offline   Reply With Quote
Old 09-08-2017, 07:59 PM   #3
Duncan10
Not Yet Wild
 
Join Date: May 2017
Posts: 9
Default Re: G2 not charging

I just put a jumper between the green on the VR to the negative of the battery. So if I understand correctly I should disconnect the green from the VR and then ground that wire I disconnected.
Duncan10 is offline   Reply With Quote
Old 09-08-2017, 10:07 PM   #4
Spicyunicorn
Gone Wild
Yamaha
 
Join Date: Jun 2015
Location: NW Iowa
Posts: 1,669
Default Re: G2 not charging

Yup disconnect it from VR and ground it so the wired foes from starter generator to ground
Spicyunicorn is offline   Reply With Quote
Old 09-08-2017, 10:22 PM   #5
Duncan10
Not Yet Wild
 
Join Date: May 2017
Posts: 9
Default Re: G2 not charging

Ok I did that and got about 13.5 V at the battery so it is charging when I do that but not like the 17 V that you indicated but I only left it on for a few seconds. Any other thoughts? Should I be leaving it longer? or should I get a new VR to check? Only trouble is finding one here in Saskatchewan, no dealers around.
Thanks for the help also much appreciated.
Duncan
Duncan10 is offline   Reply With Quote
Old 09-08-2017, 10:51 PM   #6
Spicyunicorn
Gone Wild
Yamaha
 
Join Date: Jun 2015
Location: NW Iowa
Posts: 1,669
Default Re: G2 not charging

When you checked it was it at wide open throttle?
Spicyunicorn is offline   Reply With Quote
Old 09-09-2017, 06:59 AM   #7
Duncan10
Not Yet Wild
 
Join Date: May 2017
Posts: 9
Default Re: G2 not charging

Almost wide open but it was sputtering a bit.
Duncan10 is offline   Reply With Quote
Old 09-09-2017, 09:46 PM   #8
sho305
Vegas modded 420
 
sho305's Avatar
Yamaha
 
Join Date: Jun 2009
Location: West MI
Posts: 15,327
Default Re: G2 not charging

Some of the old VR are adjustable. Some thinking now they might be better than the newer solid state ones on G9s that just go on and off. The SS ones can go on and get high voltage that some equipment does not like, such as stereos. We have not got totally to the bottom of that issue yet. Usually the gen will get full charge at a really fast idle and faster. It does not charge as much at idle/low rpm. It only charges 15A max so if your battery is toast it will have a hard time and look like its not doing well. In that case you usually would have under 12v at rest on your battery. Some of the SS are going above 15v when 'on' and that is not good for typical 12v equipment, and some LED will burn out.
sho305 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging? Electric Club Car
Charging Electric Club Car
2006 TXT 20+amps but not charging, hot charging cable Electric EZGO
Battery Charging Question (How to keep from over-charging) Electric EZGO
Charging Electric EZGO


All times are GMT -5. The time now is 08:01 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.