lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 10-19-2017, 03:33 PM   #1
marcop8702
Not Yet Wild
Yamaha
 
Join Date: Apr 2016
Posts: 16
Default G1Oil Pump setting

Ok, have. Yamaha G1 that's was running fine and then quit. Figured it was out of fuel, not sure if that's why it quit but I did put a couple gallons in the tank. Still not running. Great compression as I just replaced piston and ring and had the jug bored. Fuel is pumping through a clean filter and just put on a brand new carb. Great spark with a new plug.

Could the oil pump be bad and putting too much oil in the mix? Could it just need an adjustment? Do the oil pumps need to be adjusted regularly if so what would be the settings?

The cart ran great then it just died and won't start. It does fart and will continue to fart but it's just not enough for it to go.

Any help is appreciated.
marcop8702 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 10-19-2017, 04:52 PM   #2
Spicyunicorn
Gone Wild
Yamaha
 
Join Date: Jun 2015
Location: NW Iowa
Posts: 1,669
Default Re: G1Oil Pump setting

These pumps hardly put out any oil I don't think that is your issue here... Is the spark plug wet or dry after cranking over for awhile?
Spicyunicorn is offline   Reply With Quote
Old 10-19-2017, 05:20 PM   #3
marcop8702
Not Yet Wild
Yamaha
 
Join Date: Apr 2016
Posts: 16
Default Re: G1Oil Pump setting

Wet and the gap is set at .025.
marcop8702 is offline   Reply With Quote
Old 10-19-2017, 05:30 PM   #4
Spicyunicorn
Gone Wild
Yamaha
 
Join Date: Jun 2015
Location: NW Iowa
Posts: 1,669
Default Re: G1Oil Pump setting

I know you just rebuilt it but throw a compression gauge on it.. if you have compression fuel and spark it should run
Spicyunicorn is offline   Reply With Quote
Old 10-19-2017, 05:45 PM   #5
marcop8702
Not Yet Wild
Yamaha
 
Join Date: Apr 2016
Posts: 16
Default Re: G1Oil Pump setting

I know it's crazy. I am totally stumped. I've got all three and it will fire just not enough to go. Thanks
marcop8702 is offline   Reply With Quote
Old 10-19-2017, 06:04 PM   #6
SKETSKI
Not Yet Wild
 
SKETSKI's Avatar
Yamaha
 
Join Date: May 2016
Location: San Diego
Posts: 50
Default Re: G1Oil Pump setting

Pull the new carb off and clean the old stock one. The new China ones are good for a paper weight and thatís about it.
SKETSKI is offline   Reply With Quote
Old 10-19-2017, 06:06 PM   #7
yamahaguy97
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 1,067
Default Re: G1Oil Pump setting

Quote:
Originally Posted by SKETSKI View Post
Pull the new carb off and clean the old stock one. The new China ones are good for a paper weight and thatís about it.
You got that right
yamahaguy97 is offline   Reply With Quote
Old 10-19-2017, 06:09 PM   #8
yamahaguy97
Gone Wild
 
yamahaguy97's Avatar
Yamaha
 
Join Date: Jan 2016
Location: FL
Posts: 1,067
Default Re: G1Oil Pump setting

Also just to be sure, make sure your pedal cable is not frayed to the point where you canít start it. It happens sometimes
yamahaguy97 is offline   Reply With Quote
Old 10-19-2017, 06:20 PM   #9
marcop8702
Not Yet Wild
Yamaha
 
Join Date: Apr 2016
Posts: 16
Default Re: G1Oil Pump setting

The old carb was an after market as well, and it ran very good. Engine does the same with both carbs fires but will not run.
marcop8702 is offline   Reply With Quote
Old 10-19-2017, 06:22 PM   #10
marcop8702
Not Yet Wild
Yamaha
 
Join Date: Apr 2016
Posts: 16
Default Re: G1Oil Pump setting

Linkage to carb is good
marcop8702 is offline   Reply With Quote
Reply

Tags
fuel/oil mix, not firing, yamaha g1
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
G1 gasket for oil pump housing and for oil pump? Gas Yamaha
g1 new fuel pump still wont pump HELP Gas Yamaha
Setting toe on a G-16 Gas Yamaha
re-setting the obc Electric Club Car
the 27 hp kaw. is setting in the c.c. Big Block Talk!


All times are GMT -5. The time now is 07:41 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.