lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-06-2018, 09:52 AM   #1
logan1211
Not Yet Wild
 
Join Date: Jun 2018
Posts: 3
Default G16 performance loss after running for 5-10 minutes

Hello all! Have an older Yamaha G16 that wouldn't start when I got it. Got what I feel is the carb cleaned well enough and replaced the fuel hoses, filter, and pump and gave her a tune up. Now she fires right up and stays running without dying after 10 minutes.

However, last night I noticed that after I drive for 5-10 minutes, the power loss is very noticeable.

GPS speedometer I hit 18 mph on a flat road after getting it put together and took it out. After doing that a few times; it wouldn't go over 11 mph.

Any tips or advice on where I should I be looking next?
logan1211 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-07-2018, 10:10 PM   #2
greenskeeper
Not Yet Wild
 
Join Date: Jun 2018
Posts: 20
Default Re: G16 performance loss after running for 5-10 minutes

When it loses power does the engine sound normal and run correctly or does it miss or show a sign of fuel starvation or poor ignition?

My initial thoughts are a fuel pump issue, but that would probably show up sooner. Another thought is a coil issue that shows up once the coil gets hot.
greenskeeper is offline   Reply With Quote
Old 07-09-2018, 09:51 AM   #3
CP241
Eats dirt.
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: Michigan
Posts: 5,951
Default Re: G16 performance loss after running for 5-10 minutes

Generally if it loses power when it gets hot its a failing ignition coil, possibly ignitor. but also could be compression related. I'd check compression cold and hot just to be sure. Adjust the valves to spec. And if all else fails try another (OEM) coil.
CP241 is offline   Reply With Quote
Old 07-09-2018, 09:57 AM   #4
logan1211
Not Yet Wild
 
Join Date: Jun 2018
Posts: 3
Default Re: G16 performance loss after running for 5-10 minutes

Thanks all! When losing power; it does seem to have a little miss, just won't rev as high as normal.

I adjusted the carb just a tad yesterday and got the valves adjusted. Drove for 30 minutes and can't get it to slow down/lose power now. Going to keep an eye on it and check coil if it happens again. Appreciate the input!
logan1211 is offline   Reply With Quote
Old 07-12-2018, 08:03 PM   #5
SandbaggerYDRA
Gone Wild
 
SandbaggerYDRA's Avatar
Yamaha
 
Join Date: Nov 2012
Location: Southeastern Pa.
Posts: 302
Default Re: G16 performance loss after running for 5-10 minutes

Quote:
Originally Posted by logan1211 View Post
Thanks all! When losing power; it does seem to have a little miss, just won't rev as high as normal.

I adjusted the carb just a tad yesterday and got the valves adjusted. Drove for 30 minutes and can't get it to slow down/lose power now. Going to keep an eye on it and check coil if it happens again. Appreciate the input!
It was probably the valves. If there isn't enough gap, when the engine heats up, the metal in the push rods expands and it's possible that the value may not close completely which will rob you of compression, and produce a miss.
SandbaggerYDRA is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
76 model D quits after a few minutes of running Gas Harley Davidson
Loss of Power and Batteries Loss Charge Faster Electric EZGO
Still Not Running After 10 Minutes Gas Club Car
Slow down after a few minutes of running Electric EZGO
88 gas cc dies after running 20 minutes Gas Club Car


All times are GMT -5. The time now is 04:23 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.