lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-25-2012, 08:24 PM   #1
grover251
Not Yet Wild
 
Join Date: Mar 2010
Posts: 6
Default g16 starter problems

my starter began giving me problems so i replaced the brushes then reinstalled. cart starts and runs but stalls randomly and also noticed that when i step on accelarator the lights dim out. let off they come back on. This site has helped me alot in the past but can't find any info on my own so any help would b awesome. thanks
grover251 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-25-2012, 10:00 PM   #2
grover251
Not Yet Wild
 
Join Date: Mar 2010
Posts: 6
Default Re: g16 starter problems

took back apart found nothing but after i put back together i had nothing. jumped exciter wire on celenoid hit the throtle and it took off. confused???
grover251 is offline   Reply With Quote
Old 06-27-2012, 09:42 PM   #3
grover251
Not Yet Wild
 
Join Date: Mar 2010
Posts: 6
Default Re: g16 starter problems

thanks for all the help
grover251 is offline   Reply With Quote
Old 06-29-2012, 06:52 AM   #4
bigstik40
Gone Wild
 
bigstik40's Avatar
Yamaha
 
Join Date: Sep 2010
Location: Erie, Pennsylvania
Posts: 989
Default Re: g16 starter problems

It's pretty difficult pinpointing your problem with the description you have provided so far. I will try to help, but you will have to provide better information. I have a 97 G-16 and I also have a "shop repair manual on CD". I would like to suggest that first you go to the "stickies" and look up and copy the wiring for your cart. Next, study the wiring and try to ring out the wiring in your start circuit, to make sure "all wiring is ok". As you do this, you will notice that there are two switches and an engine stop relay in the start/run loop. Your "starting" problem could be one of these 3 items and not the starter. Your "cutting out" problem could be engine stop relay problems. I have a feeling you may have introduced an additional problem when you "fixed" the starter. Do some checking and report back with any findings and I'll try to help. Good luck - RAY
bigstik40 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Starter problems Gas Club Car
Starter Problems Gas EZGO
Starter problems Gas Club Car
Starter/Gen Problems Gas Club Car
Starter problems Gas Club Car


All times are GMT -5. The time now is 01:57 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.