lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-05-2012, 09:12 PM   #11
jrw261
Not Yet Wild
 
Join Date: Aug 2012
Posts: 9
Default Re: 81 Gas Marathon barely runs pops/backfires

The seals were definitely leaking...still repairing it though. I think I'm doing a full rebuild now... Kapow...that's the sound of my budget.
jrw261 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-05-2012, 09:19 PM   #12
kyerik
Gone Wild
E-Z-GO
 
Join Date: Aug 2012
Location: South central IL
Posts: 287
Default Re: 81 Gas Marathon barely runs pops/backfires

You should have no crank free play or movement.

I had a similar issue- my 91 Marathon (3pg) engine would only run rough when choked 90% and I had some crankshaft play (I had 140 psi compression and cleaned the carb several times). I pulled the case apart and found that the flywheel bearing was loose and the flywheel side crank seal was in really bad shape. I just put the new crank bearings on crankshaft this afternoon and I hope to have the cart running/driving by the weekend.

FYI- my crank bearings were fairly easy to install- no press was needed- just a punch and some patience. Getting the old bearings off the crank wasn't too hard either (I used a narrow chisel as a wedge). The local bearing shop had the bearings in stock for about $13 each (there are 3 of them in a 3pg engine). It is a common metric bearing and the part number is 6206.
kyerik is offline   Reply With Quote
Old 09-09-2012, 06:19 PM   #13
jrw261
Not Yet Wild
 
Join Date: Aug 2012
Posts: 9
Default Re: 81 Gas Marathon barely runs pops/backfires

I'm about to drop the motor back in. I bought new motor mounts and I'm not clear which side is up.

Clearly the plate goes on the bottom side of the sub frame but the mount has a Bushing sticking further out one side more than the other. The old ones had the short side down but all 3 mounts rested on the frame when Ide expect it to float.

Any input would be appreciated.
jrw261 is offline   Reply With Quote
Old 09-09-2012, 08:45 PM   #14
jrw261
Not Yet Wild
 
Join Date: Aug 2012
Posts: 9
Default Re: 81 Gas Marathon barely runs pops/backfires

Forget the motor mounts; I convinced myself they were correct the way they came off.
I put the motor in and got it running....it took a while to get it to fire off. I didn't make it around the yard before it started acting up. I think I'll do the HEI swap this week.

The rebuild was still worth it; the crank bearings were shot and I have a lot more compression. The short period it ran had considerably more power.
jrw261 is offline   Reply With Quote
Old 09-10-2012, 10:59 PM   #15
jrw261
Not Yet Wild
 
Join Date: Aug 2012
Posts: 9
Default Re: 81 Gas Marathon barely runs pops/backfires

I did the HEI conversion and it seems better. It spun up pretty good on jackstands...tomorrow I'll test it on the yard. It seems pretty sluggish off the bottom end like its way too rich. It might be all the prelube from the rebuild. What is the best way to tune these carbs? I'm used to something that idles. Should I lean it out until I get good throttle response the richen it up a tad?
jrw261 is offline   Reply With Quote
Old 09-11-2012, 11:11 PM   #16
jrw261
Not Yet Wild
 
Join Date: Aug 2012
Posts: 9
Default Re: 81 Gas Marathon barely runs pops/backfires

So I had the same issue when under load...it ran for about 5 minutes then started popping and carrying on. I loosened the exhaust and it backfired bad enough to blow the rear seal out of the case....sigh

I put the seal back in and retested on the stands...same result. Frustrated I reviewed some posts related to swapping the red/blue wires...it did the trick. The cart runs pretty good now. Tomorrow I'll take it for an extended ride.

BTW... I feel like I'm talking to myself here but hopefully it helps someone with a similar problem.

What blows my mind is how did all this get messed up...especially the red/blue wiring. The only thing I van think of is it started acting up because the crank seals were going bad so they richened the idle mixture. Then when that didn't cut it they swapped ignition components flipping the red/blue.. and the rest is history.
jrw261 is offline   Reply With Quote
Old 09-14-2012, 07:56 PM   #17
racin161
Gone Wild
 
Join Date: Feb 2011
Posts: 1,515
Default Re: 81 Gas Marathon barely runs pops/backfires

A blown crank seal won't let the fuel pump produce enough fuel to run properly as the pump is vacuum operated thus lack of power or no go. As for the wires and the HEI conversion for some reason swapping the wires is required don't ask why but be happy. It concerns me that it blew out the new seal when you installed it did you use blue loctite to secure it ? If not it may pop out again if it backfires. Just wondering.


LOU
racin161 is offline   Reply With Quote
Old 09-15-2012, 08:12 AM   #18
amesmotorsports
Gone Wild
 
amesmotorsports's Avatar
E-Z-GO
 
Join Date: May 2011
Location: Michigan
Posts: 269
Default Re: 81 Gas Marathon barely runs pops/backfires

on my 1989 I replaced alot before finding out it was a bad coil. I was shorting out from a bare wire on the coil. 5 min check?
amesmotorsports is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1999 48 volt club car IQ barely runs slow Electric Club Car
Cushman 22 hp runs rough and backfires Gas golf carts
My motor runs, but my cart barely moves. Electric EZGO
'93 G9 Gas - barely runs after after electrical issue Gas Yamaha
89 parcar rebuild, barely runs..wrong piston? Gas Columbia ParCar


All times are GMT -5. The time now is 01:51 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.