lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 03-06-2014, 09:22 PM   #1
98 SNAKE EATER
Getting Wild
 
Join Date: Mar 2009
Posts: 91
Question My buggy sat for over a year......need a little help

So our Villager 8 sat in the elements for well over a year now






Did the usual fixes...

Drained/cleaned gas tank, tore carb apart and cleaned out all the gunk, replaced all fuel lines, fuel filters, air filter, oil filter, fresh oil, new spark plug and replaced the dead battery.

Also had to replace a busted air cleaner hose and the fuel pump needed a good cleaning as well.

Cold cranking, there's no fuel flow

If I spray a little starter fluid, she cranks right up.

Do it a few times and the fuel starts flowing.

Once the fuel hits the carb, she'll sit there and idle all day long without a hiccup

Took her for a spin and all seemed well.

Did multiple warm starts before leaving for work this morning and had zero issues

Got back home about an hour ago and tried to start her up, but no fuel flow in either of the filters

Sprayed a little starter spray and as soon as she built up some revs, the fuel started flowing and she was good to go again.

I'm guessing the fuel pump is on its way out and needs more than a low rev pulse from the motor to get going.

Anyways, before I get a new pump, I figured I'd post up here to see if I overlooked anything that would cause the same issue

Any suggestions for a pump upgrade or should I just go with a stock replacement Mikuni pump?
98 SNAKE EATER is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 03-06-2014, 10:47 PM   #2
KillerCC
Call me Rich
 
KillerCC's Avatar
Club Car
 
Join Date: Mar 2011
Location: Western NY
Posts: 1,155
Default Re: My buggy sat for over a year......need a little help

A lot of times when the work you did has been done, usually if you add some pressure into the gas tank, everything will work fine. Usually I use a blow gun and shoot some small puffs of air into the tank fill opening while holding my hand over it to help keep the pressure from escaping. Do this while some one is trying to start it and it should work. Good luck!
KillerCC is offline   Reply With Quote
Old 03-06-2014, 11:08 PM   #3
98 SNAKE EATER
Getting Wild
 
Join Date: Mar 2009
Posts: 91
Default Re: My buggy sat for over a year......need a little help

Quote:
Originally Posted by KillerCC View Post
A lot of times when the work you did has been done, usually if you add some pressure into the gas tank, everything will work fine. Usually I use a blow gun and shoot some small puffs of air into the tank fill opening while holding my hand over it to help keep the pressure from escaping. Do this while some one is trying to start it and it should work. Good luck!
That would probably work to get it started initially, but I don't want to be doing that during every cold start

Once she's started and warms up for a minute or so, the fuel flows fine and I can stop and start with ease, but during cold starts, it seems to take forever to get the fuel flowing
98 SNAKE EATER is offline   Reply With Quote
Old 03-06-2014, 11:43 PM   #4
KillerCC
Call me Rich
 
KillerCC's Avatar
Club Car
 
Join Date: Mar 2011
Location: Western NY
Posts: 1,155
Default Re: My buggy sat for over a year......need a little help

Yeah sorry. Sounds like you'll be needing a pump or rebuild yours. You can pretty much use any gravity pump. There are definitely cheaper ones than the club car brand.
KillerCC is offline   Reply With Quote
Old 03-07-2014, 07:37 AM   #5
SickPup404
Not Yet Wild
Club Car
 
Join Date: Feb 2014
Location: Sussex County, Delaware
Posts: 62
Default Re: My buggy sat for over a year......need a little help

I just got
this one this one
for my 1998 CC DS and it works fine. Not sure if that's the same one you'll need.

HTH & GL!
SickPup404 is offline   Reply With Quote
Old 03-07-2014, 09:24 AM   #6
98 SNAKE EATER
Getting Wild
 
Join Date: Mar 2009
Posts: 91
Default Re: My buggy sat for over a year......need a little help

Quote:
Originally Posted by SickPup404 View Post
I just got this one for my 1998 CC DS and it works fine. Not sure if that's the same one you'll need.

HTH & GL!
Looks identical to what it came with, but when I checked Mikuni's listing, they show many that look the same but have different part numbers

I've also seen some people refer to this one as high volume

http://www.ebay.com/itm/OEM-Mikuni-F...item3a81604c46

It's cheaper and doesn't really look as good as the original (plastic?)
98 SNAKE EATER is offline   Reply With Quote
Old 03-09-2014, 09:36 PM   #7
ckiguy
Bad *** Speller!
 
ckiguy's Avatar
Club Car
 
Join Date: Oct 2009
Location: Columbus, Ohio
Posts: 1,338
Default Re: My buggy sat for over a year......need a little help

snake you tried to clean the pump out? not hard to do, just unsrew it from frame, put on a work area and unsrew the 4 screws. split the case carefully, and you can clean he goo out that way and inspect your diaghram.i appli a bit of antiseize to the screws before i reinstall. mine hardly has any fuel in it unless i have at leats 3/4 ways of fuel. fires right up n issues, and i never see fuel in the flter.
ckiguy is offline   Reply With Quote
Old 03-10-2014, 12:42 AM   #8
98 SNAKE EATER
Getting Wild
 
Join Date: Mar 2009
Posts: 91
Default Re: My buggy sat for over a year......need a little help

Yes, I took the pump apart and cleaned it, but reused the same old seals.

There was quite a bit of sediment in there.

The cold starting issue seems to be getting better the more I run the cart, but it still takes a 15 seconds or so to get going from stone cold.

Silly question since I already had the carb apart, but does it have some sort of a priming circuit?

Like sumthin that would give it a shot of gas from the bowl when I hit the accelerator pedal?

It seems that's all it would really need since she fires right up with a shot of starter fluid.

That being said, it seems I have another problem I have to tend to...

The shifter cable has frayed right above the muffler, causing it to grind when I throw it in reverse

Being it's a limo, I'm sure that will cost an arm and a leg
98 SNAKE EATER is offline   Reply With Quote
Old 03-10-2014, 03:45 PM   #9
DOOmsman
Gone Wild
 
DOOmsman's Avatar
Yamaha
 
Join Date: Jul 2008
Location: Reddick IL
Posts: 10,986
Default Re: My buggy sat for over a year......need a little help

It does not have a shot of gas it uses an emulsifier jet for low end.
Did you use a wire in the tiny holes on the side of the jet.


Also http://www.buggiesgonewild.com/gas-y...fuel-pump.html
DOOmsman is offline   Reply With Quote
Old 03-10-2014, 06:57 PM   #10
98 SNAKE EATER
Getting Wild
 
Join Date: Mar 2009
Posts: 91
Default Re: My buggy sat for over a year......need a little help

Yes, I pulled it and went through it with a wire tie (it was pretty gunked up) as well as letting it soak for a while before blowing through it with a shot of air.

I'm pretty sure it's just the pump not being effective at low starting RPM's because after it's been sitting for a while and the fuel filters show a little air gap from leaking down, you can see them fill up very slowly with cold cranking only.

However, with a shot of start fluid in the air inlet, I can crank and when it immediately fires up, you can see the filters fill up much faster.

Once the filters are full and the lines appear to have pressure, she starts right up with ease.
98 SNAKE EATER is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
PVC Buggy Side x Sides-ATV-Quads-Bikes-Jeeps-4x4's!
Bad Boy Buggy - Need Help Lifted Golf Carts
Bad Boy Buggy Help??? Electric golf carts
My New Buggy Members Rides


All times are GMT -5. The time now is 03:49 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.