lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 10-14-2009, 01:23 PM   #1
karenms22
Not Yet Wild
Yamaha
 
Join Date: Oct 2009
Location: Northern CA
Posts: 3
Default Yamaha G19 hesitation when starting

Just bought a Yamaha G19 electric cart a week ago. First time out in the middle of the day, noticed a little slight 1second delay when stepping on gas, attributed it to not knowing the cart. Next day, left at 7am, got up to the golf course, stepped on the gas, got a little buzzing sound, very slight movement. If you kept your foot on the gas for several (10+) seconds, the cart would move perfectly normal. You could ease off the gas and go again with no problem, but if you let completely off of it, you were back at square 1. After an hour of checking wires, we loaded up went home. When we got home, cart ran perfect. Found a loose connection, plugged it in, thought that was the problem. Ran the cart all week after work, no problems at all. Left for the golf course with fully charged cart at 7am the next morning, get there, exact same thing as last weekend. The cold was obviously having an impact on a larger issue. We wiggled a wire, not hard, cart then completely lost power, no more reverse buzzer.

Very frustrating, any ideas. We were thinking solenoid, as the last times we turned the key to the on position we were getting no "click". Would a solenoid going out cause total power failure?? Upon inspection, it has a 2002 controller in it, the batteries are newer (less than a year old), and the solenoid was the only really crusty looking thing on the cart.
karenms22 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 10-16-2009, 12:44 PM   #2
karenms22
Not Yet Wild
Yamaha
 
Join Date: Oct 2009
Location: Northern CA
Posts: 3
Default Re: Yamaha G19 hesitation when starting

I did some more checking, as it turns out the fuse was blown, but not easy to see. Had checked it, but until I put it under light and looked more carefully it was very hard to see. Cart has power again, and seems to run ok, but its been in a garage, don't understand why the cold causes it to stop running.
karenms22 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Marathon Hesitation Gas EZGO
Hesitation Problems Gas Club Car
Gas Yamaha has trouble starting Gas Yamaha
hesitation when taking off Electric Club Car
Hesitation Big Block Talk!


All times are GMT -5. The time now is 10:37 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.