lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-28-2020, 06:47 PM   #11
CP241
Nincompoop village idiot
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: Michigan
Posts: 9,590
Default Re: Weird issue, cart wonít stay running

Start with the basics :)

You can "rent" a compression tested from most auto parts stores for free. Just leave a deposit and they'll refund it when you return it.

There really isn't a whole lot to these motors. They're really pretty basic, but it's helpful to have a whole picture when trying to help over the internet

If compression is good we can check some other things. But its best to not assume anything and start fresh:)
CP241 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-29-2020, 10:16 AM   #12
Largemouth21
Not Yet Wild
 
Join Date: Jul 2020
Posts: 32
Default Re: Weird issue, cart wonít stay running

Quote:
Originally Posted by CP241 View Post
Start with the basics :)

You can "rent" a compression tested from most auto parts stores for free. Just leave a deposit and they'll refund it when you return it.

There really isn't a whole lot to these motors. They're really pretty basic, but it's helpful to have a whole picture when trying to help over the internet

If compression is good we can check some other things. But its best to not assume anything and start fresh:)
My boss is going to rent a compression gauge next time he is in town. Until then, what are some other things I can test? I donít understand how it decides to only run sometimes. Fuel is the only thing Iím 100% positive of
Largemouth21 is offline   Reply With Quote
Old 07-29-2020, 11:14 AM   #13
CP241
Nincompoop village idiot
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: Michigan
Posts: 9,590
Default Re: Weird issue, cart wonít stay running

Auto zone, oreilly, etc rent them for free. You pay 50 bucks or whatever to use it and they refund it 100% when you return it.

I've got a suspicion your compression is low. But id want to confirm im wrong before diving in deep
CP241 is offline   Reply With Quote
Old 07-29-2020, 12:10 PM   #14
Largemouth21
Not Yet Wild
 
Join Date: Jul 2020
Posts: 32
Default Re: Weird issue, cart wonít stay running

Quote:
Originally Posted by CP241 View Post
Auto zone, oreilly, etc rent them for free. You pay 50 bucks or whatever to use it and they refund it 100% when you return it.

I've got a suspicion your compression is low. But id want to confirm im wrong before diving in deep
Welp, you were right 58psi in one cylinder and 60 in the other, I wonder why it ran good sometimes.... not sure how accurate the gauge is though
Largemouth21 is offline   Reply With Quote
Old 07-29-2020, 02:40 PM   #15
CP241
Nincompoop village idiot
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: Michigan
Posts: 9,590
Default Re: Weird issue, cart wonít stay running

Make sure you hold the throttle at the carb wide open with your hand while cranking. Don't rely on the pedal, the cable being out of adjustment may not hold the throttle wide open with the pedal...

Also, double check the valve lash. I know you already said you set it, but I use .004 on all 4 of them. You'll have to rotate the engine over a half rotation to set the 2nd cylinder. And pay particular attention to the 2 valves in the middle (intake) they're known to wear so if you have considerably more threads showing on top.of the adjuster lock nut on those vs. The exhaust valves on the outside, you'll need to replace them. Once they're worn your compression can suffer, despite nothing at all being wrong with the bottom half of the motor.

If you're unsure what I'm describing just post a picture. Many of us can tell at a glance if they're worn or not.
CP241 is offline   Reply With Quote
Old 07-30-2020, 12:17 AM   #16
Cartmaster
British born Nincompoop
 
Cartmaster's Avatar
E-Z-GO
 
Join Date: Feb 2007
Location: United Kingdom
Posts: 2,443
Default Re: Weird issue, cart wonít stay running

On these engines, As CP has already stated. The first thing i would have done was a compression check. You have found it very low, which suggests worn intake valves rather than ring wear or valve guide seals as you have not mention a smoking exhaust. Severe wear on the valves will drop compression drastically and cause poor starting and fading out on power.

One question. Is there oily residue in the air filter box?

As CP said, show us a picture of the lash adjusters. We like pictures LOL.
Cartmaster is offline   Reply With Quote
Old 07-31-2020, 03:14 PM   #17
Largemouth21
Not Yet Wild
 
Join Date: Jul 2020
Posts: 32
Default Re: Weird issue, cart wonít stay running

Quote:
Originally Posted by CP241 View Post
Make sure you hold the throttle at the carb wide open with your hand while cranking. Don't rely on the pedal, the cable being out of adjustment may not hold the throttle wide open with the pedal...

Also, double check the valve lash. I know you already said you set it, but I use .004 on all 4 of them. You'll have to rotate the engine over a half rotation to set the 2nd cylinder. And pay particular attention to the 2 valves in the middle (intake) they're known to wear so if you have considerably more threads showing on top.of the adjuster lock nut on those vs. The exhaust valves on the outside, you'll need to replace them. Once they're worn your compression can suffer, despite nothing at all being wrong with the bottom half of the motor.

If you're unsure what I'm describing just post a picture. Many of us can tell at a glance if they're worn or not.
I had the throttle all the way open, and I did notice one cylinder seemed to ďbleedĒ the pressure faster than the other. Do you think that could be a sign of a valve issue? It doesnít smoke when I can get it started so I think maybe itís a valve issue
Largemouth21 is offline   Reply With Quote
Old 07-31-2020, 03:16 PM   #18
Largemouth21
Not Yet Wild
 
Join Date: Jul 2020
Posts: 32
Default Re: Weird issue, cart wonít stay running

Quote:
Originally Posted by Cartmaster View Post
On these engines, As CP has already stated. The first thing i would have done was a compression check. You have found it very low, which suggests worn intake valves rather than ring wear or valve guide seals as you have not mention a smoking exhaust. Severe wear on the valves will drop compression drastically and cause poor starting and fading out on power.

One question. Is there oily residue in the air filter box?

As CP said, show us a picture of the lash adjusters. We like pictures LOL.
I think youíre right, I just donít understand how it can run good for a few seconds and even drive for a while (I went about 1/4 mile) and then just sputter out and not restart. Iíll post a pic of valves
Largemouth21 is offline   Reply With Quote
Old 07-31-2020, 03:24 PM   #19
Largemouth21
Not Yet Wild
 
Join Date: Jul 2020
Posts: 32
Default Re: Weird issue, cart wonít stay running

Hereís the head, about 2 threads showing on each
Can somebody please explain how a motor can run fine for a while if thexompression is really the issue? I got it to start and run fine for 1/4 mile but idk Iíd it was full power or not, Cart is new to me
Attached Images
File Type: jpg 6C1BF4DD-0A17-4BBA-9C0B-7FC7B965281F.jpg (119.9 KB, 0 views)
Largemouth21 is offline   Reply With Quote
Old 07-31-2020, 03:26 PM   #20
Largemouth21
Not Yet Wild
 
Join Date: Jul 2020
Posts: 32
Default Re: Weird issue, cart wonít stay running

Quote:
Originally Posted by Cartmaster View Post
On these engines, As CP has already stated. The first thing i would have done was a compression check. You have found it very low, which suggests worn intake valves rather than ring wear or valve guide seals as you have not mention a smoking exhaust. Severe wear on the valves will drop compression drastically and cause poor starting and fading out on power.

One question. Is there oily residue in the air filter box?

As CP said, show us a picture of the lash adjusters. We like pictures LOL.
Thanks for the help, I just posted a pic, there was a weird watery black/brown liquid in the air box, but wasnít oily, I just removed the air box to work on it
Largemouth21 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Won't stay running Gas Club Car
2006 DS gas cart will not stay running Gas Club Car
Wiring The Cart To Stay Running Gas EZGO
must pump gas pedal to get cart to stay running Gas Yamaha
'81 2 cycle cart wont stay running.... Gas EZGO


All times are GMT -5. The time now is 07:12 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.