lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-04-2020, 06:20 PM   #21
Mcmeadows
Not Yet Wild
 
Join Date: May 2019
Posts: 15
Default Re: 97 gas EZGO low power

Thanks. I have never taken a motor out but have taken off most everything else. I did watch some of that video and was wondering the whole time if I should be watching it because of him not being real sure about what he was doing. Is there anything else youíd recommend me doing while I have the motor out?
Mcmeadows is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-04-2020, 06:31 PM   #22
trig123
Vintage tech
E-Z-GO
 
Join Date: Sep 2009
Location: South
Posts: 3,210
Default Re: 97 gas EZGO low power

If you know 100 % sure the rest of the engine is ok then I would put a new timing belt, rear cylinder head seal, two intake valves and head gasket.

If you do decide to do this take pictures as you go. Put the rockers on just the way they came off when putting it back. I run a long all thread or something through them to keep them in place.

The valve springs can be pushed in with your fingers or make you a tool to do it with. Don't let those tiny keepers fly by your head and go missing on you lol

Get some lapping compound and lap the valves in head. You should see a fine line in middle of valve if they seat good. I don't ever replace the exhaust valves but look at them good anyway.
trig123 is offline   Reply With Quote
Old 08-04-2020, 08:32 PM   #23
Walpage
Not Yet Wild
 
Join Date: Aug 2020
Posts: 2
Default Re: 97 gas EZGO low power

I was having a similar issue. Ď85 ezgo was running fine. Suddenly just didnít have it. Checked everything, cleaned carb, fuel pump, ..... nothing. Would creep along but no speed or power. Saw a thread earlier said to check for a plugged muffler. I opened the flange up at the muffler and wedged it open with a screwdriver to try. Wow! Felt like I was flyin! Give it a try. Wonít hurt. Solved my problem! 😊
Walpage is offline   Reply With Quote
Old 08-04-2020, 11:03 PM   #24
trig123
Vintage tech
E-Z-GO
 
Join Date: Sep 2009
Location: South
Posts: 3,210
Default Re: 97 gas EZGO low power

Quote:
Originally Posted by Walpage View Post
I was having a similar issue. Ď85 ezgo was running fine. Suddenly just didnít have it. Checked everything, cleaned carb, fuel pump, ..... nothing. Would creep along but no speed or power. Saw a thread earlier said to check for a plugged muffler. I opened the flange up at the muffler and wedged it open with a screwdriver to try. Wow! Felt like I was flyin! Give it a try. Wonít hurt. Solved my problem! 😊
The 1985 had the 2-stroke and intake valves are not used. The muffler being plugged up would not make it have low compression also. 2-strokes most of the time use mix and the muffler would sometimes get stopped up more than these 4-strokes.
trig123 is offline   Reply With Quote
Old 08-31-2020, 04:50 PM   #25
Mcmeadows
Not Yet Wild
 
Join Date: May 2019
Posts: 15
Default Re: 97 gas EZGO low power

Well i finally was able to replace intake valves but.... Don't know if i did it right. Got the motor back in and it wont crank. It is spitting gas out of carb into air box. I read some posts on here saying it could be valve related, or timing belt. Either could be possible. I also forgot about keeping the rockers in the correct order until after i had partially mixed them up, so I could have them right or maybe not. Any suggestions?
Mcmeadows is offline   Reply With Quote
Old 08-31-2020, 05:33 PM   #26
trig123
Vintage tech
E-Z-GO
 
Join Date: Sep 2009
Location: South
Posts: 3,210
Default Re: 97 gas EZGO low power

Did you go by the manual when timing it ? are your valves adjusted correct ?
trig123 is offline   Reply With Quote
Old 08-31-2020, 07:11 PM   #27
Mcmeadows
Not Yet Wild
 
Join Date: May 2019
Posts: 15
Default Re: 97 gas EZGO low power

I did adjust the valves. The timing I paid no attention to just put it back in. Iíll get that straight and try again.
Mcmeadows is offline   Reply With Quote
Old 08-31-2020, 08:24 PM   #28
trig123
Vintage tech
E-Z-GO
 
Join Date: Sep 2009
Location: South
Posts: 3,210
Default Re: 97 gas EZGO low power

Quote:
Originally Posted by Mcmeadows View Post
I did adjust the valves. The timing I paid no attention to just put it back in. Iíll get that straight and try again.
Make sure it is this way
Attached Images
File Type: jpg robbins timing.jpg (102.6 KB, 0 views)
trig123 is offline   Reply With Quote
Old 09-12-2020, 02:15 PM   #29
Mcmeadows
Not Yet Wild
 
Join Date: May 2019
Posts: 15
Default Re: 97 gas EZGO low power

I put on a new timing belt correctly. Broke the old one trying to get it back on. It is firing up now but smoking a little and thereís an oil leak right by this bolt Iím pointing to in the picture. Also I canít get this bolt to tighten down. Would that be causing the oil leak? Or does this bolt just hold the cover on?
Attached Images
File Type: jpg 712EF5CB-6A90-4E20-8A6E-5983A17EB622.jpg (186.9 KB, 0 views)
Mcmeadows is offline   Reply With Quote
Old 09-21-2020, 03:36 PM   #30
Mcmeadows
Not Yet Wild
 
Join Date: May 2019
Posts: 15
Default Re: 97 gas EZGO low power

Got the oil leak worked out. I'm pretty much back in the same place where I started now. 90-95 is the compression on both sides. I'm considering buying a rebuilt engine to put in it. What else could be causing low compression? Could it be the intake valves not seated well?
Mcmeadows is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1995 ezgo medalist power, new batteries, no power to the solenoid Electric EZGO
ezgo no power Electric EZGO
'90 EZGO with no power Gas EZGO
Ezgo dies under power then regains power Electric EZGO
have power on ezgo buggy no power light Electric EZGO


All times are GMT -5. The time now is 06:58 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.