lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-22-2020, 07:55 AM   #1
Night life
Gone Wild
 
Night life's Avatar
Club Car
 
Join Date: Oct 2014
Location: South Florida
Posts: 241
Default Throttle sensitivity issue

Hello,

Over the last month or 2 my throttle has been “off”. From a stop, the cart wants to take off to 1/2 or more speed instantly and I can not keep a low/slow speed whatsoever. I assumed the MCOR was bad as I seem to get 2 or so years out of them. Replaced with factory Mexico mcor4 and no change. Obviously I know I can re adjust my maps on the xct controller, but I used to be able to run the car fine which makes me think there is a different issue. All mods in signature below.

Any help is appreciated..
Thanks,
Barry
Night life is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-22-2020, 08:04 AM   #2
Sergio
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 9,329
Default Re: Throttle sensitivity issue

You can clear the throttle auto-calibration in case it is a temporary issue.

Do You have anything connected to the extra black/yellow negative wire behind the dash?

If so disconnect it and run a separate negative to whatever is connected there.

My original MCOR is 10 years old and still works fine.
Sergio is offline   Reply With Quote
Old 09-22-2020, 08:22 AM   #3
Night life
Gone Wild
 
Night life's Avatar
Club Car
 
Join Date: Oct 2014
Location: South Florida
Posts: 241
Default Re: Throttle sensitivity issue

Hi Sergio, I will try that.

I do not, all negatives are ran from the pack.
Night life is offline   Reply With Quote
Old 09-22-2020, 08:50 AM   #4
Night life
Gone Wild
 
Night life's Avatar
Club Car
 
Join Date: Oct 2014
Location: South Florida
Posts: 241
Default Re: Throttle sensitivity issue

Auto calibration reset was the ticket! Assuming it learned against the bad mcor. Or maybe the old mcor wasn’t bad?

Running smooth now!
Night life is offline   Reply With Quote
Old 09-22-2020, 09:04 AM   #5
Sergio
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 9,329
Default Re: Throttle sensitivity issue

If the old MCOR had a micro-switch problem then it could have caused the problem since the auto-calibration uses the pedal micro-switch signal to determine the zero throttle position.
Sergio is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
G19E brake sensitivity Electric Yamaha
Speed and Throttle Issue Troubleshooting. MCOR Issue? Electric Club Car
96 g-16 gas throttle issue Gas Yamaha
Throttle issue? Electric Club Car
Modified Precedent Pedal Sensitivity Electric Club Car


All times are GMT -5. The time now is 05:55 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.