lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-11-2008, 04:17 AM   #1
stevend
Not Yet Wild
 
stevend's Avatar
 
Join Date: Dec 2007
Location: Prairieville, Louisiana
Posts: 7
Default charging problem

Just got my CC up and running. Runs great, but it isn't charging. The battery seems to hold a charge fine. The starter/generator is brand new. I am thinking it is the voltage regulator. Any ideas? I assume I can check the regulator with a volt meter, should it be putting out 12 volts? Remeber I'm the guy with the cart that has seen salt water use and the voltage regulator doesn't look very happy. Will try to post some pic's soon.
stevend is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 02-17-2008, 08:13 PM   #2
phasetim
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: charging problem

check your wires from starter generator to voltage regulator... if they are all well, then I would say regulator is fine....
phasetim is offline   Reply With Quote
Old 02-19-2008, 04:25 AM   #3
stevend
Not Yet Wild
 
stevend's Avatar
 
Join Date: Dec 2007
Location: Prairieville, Louisiana
Posts: 7
Default Re: charging problem

Thanks for the reply. I have since dug into the problem and found that the oil switch and regulator wires were crossed. Both are yellow wires. I guess my oil light is fully charged now!
stevend is offline   Reply With Quote
Old 02-19-2008, 07:26 AM   #4
phasetim
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: charging problem

LOL, glad it was simple! :-)
phasetim is offline   Reply With Quote
Old 02-19-2008, 12:49 PM   #5
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 73,324
Default Re: charging problem

That's Funny!! Good to see you figured it out. Were you able to confirm the generator output?
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging problem 1996 Club Car 48V DS non-regen cart Electric Club Car
A 48v charging problem Electric Club Car
charging 48, 60, 72 volts Extreme DC!
marathon charging? Gas EZGO
charging problem Electric Yamaha


All times are GMT -5. The time now is 04:47 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.