lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-20-2011, 02:33 PM   #1
Plumbergs
Getting Wild
 
Plumbergs's Avatar
E-Z-GO
 
Join Date: Jul 2011
Posts: 133
Question 83 Ezgo, Freshly rebuilt engine, getting fuel & spark, but won't fire up. Help?

Me again, back for more help from the experts.

Got the freshly rebuilt 2PG back in my cart yesterday, and it still won't even try to crank. Here's all the details to help with the diagnosis..

1) Like I said, the engine has been compltely rebuilt.. New crank, seals, piston, cylinder, the whole 9 yards.

2) I haven't checked the compression yet (I have to borrow a tester and check it tomorrow) but I believe its fine because I took out the plug and tried putting my finger over the hole while cranking the engine.. I couldn't keep my finger over the hole, so I'm thinking the compression is fine. I'll test and post the actual numbers soon.

3) Its getting a good stream of fuel from the fuel pump. I recorded a short video so that you can see for yourself:
Click here to watch the video

4) I even took off the carb and tried spraying fuel directly into the elbow above the reed valve. Also took out the plug and sprayed a little fuel in the cylinder. Nothing.. Not even a backfire.

5) The plug is firing.

6) I checked the reed valve.. Its installed properly and looks fine.

7) At first I thought maybe it could be the timing.. But I know I put the pulsar in the proper position.. Plus if it were the timing, I should still get a backfire or something. I'm not getting anything. Its not trying to fire at all.

8 ) Muffler has been BBQ'd and isn't clogged.

I know the engine needs 3 things to run.. Fuel, Air and Spark.

*Fuel - I believe I've eliminated this one as being the culprit because like I said, I sprayed some directly into the cylinder.

* Air - I think this one is eliminated as well because I checked the reed valve (its fine), no obstructions on the intake side, compression is good, and the muffler was just BBQ'd.

*Spark - I pulled the plug out of the head and held it against the block while turning the engine over. It was firing. Tried two different plugs. One plug was firing a blue spark and the other was orange. (I know blue = better).

The only thing I can think of is that even though the plug is firing, maybe its not getting enough spark to ignite the fuel?

What do you guys think? Suggestions?
Plumbergs is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-20-2011, 03:11 PM   #2
Dave Box
Respect the Cart
 
Dave Box's Avatar
E-Z-GO
 
Join Date: May 2010
Location: Rocky Mount, Virginia
Posts: 2,190
Default Re: 83 Ezgo, Freshly rebuilt engine, getting fuel & spark, but won't fire up. Help?

Are you starting with a brand new spark plug? The reason I ask is that I have seen plugs that fire when not under compression i.e. out of the cylinder but fail in the engine. This seems to be more prevalent on 2 strokes. If you are putting fuel directly into the cylinder then, as you say you should at least get a backfire.

Dave
Dave Box is offline   Reply With Quote
Old 09-20-2011, 03:13 PM   #3
Plumbergs
Getting Wild
 
Plumbergs's Avatar
E-Z-GO
 
Join Date: Jul 2011
Posts: 133
Default Re: 83 Ezgo, Freshly rebuilt engine, getting fuel & spark, but won't fire up. Help?

Quote:
Originally Posted by Dave Box View Post
Are you starting with a brand new spark plug? The reason I ask is that I have seen plugs that fire when not under compression i.e. out of the cylinder but fail in the engine. This seems to be more prevalent on 2 strokes. If you are putting fuel directly into the cylinder then, as you say you should at least get a backfire.

Dave
Ok, that makes sense. I'll grab a new plug today and report back tomorrow. Thanks Dave!
Plumbergs is offline   Reply With Quote
Old 09-21-2011, 01:05 PM   #4
Plumbergs
Getting Wild
 
Plumbergs's Avatar
E-Z-GO
 
Join Date: Jul 2011
Posts: 133
Thumbs up Re: 83 Ezgo, Freshly rebuilt engine, getting fuel & spark, but won't fire up. Help?

Dave,
It turned out to be a bad plug wire.. I substituted the wire from my John Deere 314 and it fired right up!
Plumbergs is offline   Reply With Quote
Old 09-21-2011, 02:24 PM   #5
madoc1
no clue
 
madoc1's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: spicewood, texas
Posts: 3,308
Default Re: 83 Ezgo, Freshly rebuilt engine, getting fuel & spark, but won't fire up. Help?

way to go plum! be sure to run the fist tank at 40/1, then switch to 128/1. let us know how it performs. now you are the new expert.
madoc1 is offline   Reply With Quote
Old 09-21-2011, 04:55 PM   #6
Dave Box
Respect the Cart
 
Dave Box's Avatar
E-Z-GO
 
Join Date: May 2010
Location: Rocky Mount, Virginia
Posts: 2,190
Default Re: 83 Ezgo, Freshly rebuilt engine, getting fuel & spark, but won't fire up. Help?

Well done Plumberg you have earned your chops and are now a maven amongst men.

Dave
Dave Box is offline   Reply With Quote
Old 09-21-2011, 05:52 PM   #7
Plumbergs
Getting Wild
 
Plumbergs's Avatar
E-Z-GO
 
Join Date: Jul 2011
Posts: 133
Default Re: 83 Ezgo, Freshly rebuilt engine, getting fuel & spark, but won't fire up. Help?

Thanks Madoc & Dave. Like I said in the build thread, I couldn't have done it without you guys.
Plumbergs is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Rebuilt my 87 EZGO Engine, still having issues, please help!!! Gas EZGO
Need rebuilt EZGO 350cc engine Gas EZGO
Freshly Rebuilt G1 w/90 lbs Compression Gas Yamaha
Spark and Fuel! No Fire Gas EZGO
rebuilt 295 ezgo engine Golf Carts and Parts


All times are GMT -5. The time now is 04:57 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.