lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-29-2020, 04:16 PM   #1
horaceman
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2019
Location: Georgia
Posts: 30
Default 4" All Sports Lift and Brake Issues

I have seen quite a number of posts where people have been having brake issues after installing a lift. I just finished installing a 4" All Sports lift and now having brake issues. The pedal is not as tight as it was pre-lift and the driver side wants to lock up when pressing the pedal.

Also, when pressing the brake pedal, I can feel it slightly pulsing and seems like it starts to press back towards me. I tightened the U bolts as tight I can to prevent the axle from rolling and is slightly better but still experiencing the issue.

I'm not sure if the longer driver side cable will take care of these issues or not. I removed the cable clip that was attached to the front leaf spring bolt and the cable does not appear to be too tight.

Any recommendation?
horaceman is offline   Reply With Quote
Old 06-29-2020, 04:55 PM   #2
JWreck
Getting Wild
Club Car
 
Join Date: Nov 2019
Location: Austin TX
Posts: 101
Default Re: 4" All Sports Lift and Brake Issues

I had the exact issues you’re describing. I too was skeptical a slightly longer cable would fix it.

But this weekend I installed it, and they’re butter smooth now (also replaced pads).

Get the longer cable from David. Quick shipping and it’ll fix it based on my limited experience.

PS It was a pain to push the tabs in to remove the cable. If anyone can share tips to make his life easier....otherwise best of luck sir.
JWreck is offline   Reply With Quote
Old 06-30-2020, 05:46 AM   #3
horaceman
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2019
Location: Georgia
Posts: 30
Default Re: 4" All Sports Lift and Brake Issues

I received a call from All Sports and they instructed me to make sure the driver side brake cable was disconnected from the front leaf spring bolt, lift the rear of the cart so both tires were off the ground and loosen all the U bolts. Then tightened the two front bolts first thereby rotating the axle and motor back towards the club well. This changed the angle of the driver side brake cable and stopped it from binding. Finally, tightened the rear bolts. When complete, the front U bolts had about 3/8” more thread showing than the rear bolts. This resolved my issues with the brakes pulsating and locking up.


Sent from my iPhone using Tapatalk
horaceman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
All-Sports Rear Lift Kit Install "My Way" Electric Club Car
lift of '03 gas CC DS, 6" all sports SS Gas Club Car
All Sports ASM-Y22 G-MAX/G22 6" Lift Kit Lifted Golf Carts
8" all sports lift Lifted Golf Carts
Club Car w/ 4" All Sports SS lift and 20" tires Lifted Golf Carts


All times are GMT -5. The time now is 09:47 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.