lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-19-2013, 09:42 AM   #1
Jimbo2012
Gone Wild
 
Join Date: Apr 2012
Posts: 167
Question Can't move at all - Help

I have a 1997 CC (serial # A97) it is a 4 x 12 V cart

Was running, stopped for 5 minutes and now can't get this moving,

batteries are fully charged on my multi-meter.

No clicking or any noise.

Is there a step by step process of elimination?
Jimbo2012 is offline   Reply With Quote
Old 09-19-2013, 11:31 AM   #2
jakesnake27
Gone Wild
 
Join Date: Aug 2009
Posts: 14,245
Default Re: Can't move at all - Help

Did you convert it to 12v batteries? A 97 should have six 8v batts...
Does the reverse buzzer sound when in reverse? Do you hear a click when you step on the gas?
jakesnake27 is offline   Reply With Quote
Old 09-19-2013, 11:44 AM   #3
Jimbo2012
Gone Wild
 
Join Date: Apr 2012
Posts: 167
Default Re: Can't move at all - Help

Quote:
Originally Posted by jakesnake27 View Post
Did you convert it to 12v batteries? A 97 should have six 8v batts...
Does the reverse buzzer sound when in reverse? Do you hear a click when you step on the gas?
It had 4 x 12 when i got it, been running for a few months.

No buzzer, never was one.

No click when depressing gas pedal

It has a grey plastic box for a controller.

When I let off the gas down hill it acts like a regen but no regen switch.

I see 4 posts on the motor and a small pigtail.

Thanks
Jimbo2012 is offline   Reply With Quote
Old 09-19-2013, 11:46 AM   #4
jakesnake27
Gone Wild
 
Join Date: Aug 2009
Posts: 14,245
Default Re: Can't move at all - Help

Ok, does it have a Run/Tow switch under the seat?
If the little pigtail comes off the end of the motor, that is the speed sensor, which is for regen braking...
jakesnake27 is offline   Reply With Quote
Old 09-19-2013, 11:54 AM   #5
Jimbo2012
Gone Wild
 
Join Date: Apr 2012
Posts: 167
Default Re: Can't move at all - Help

Quote:
Originally Posted by jakesnake27 View Post
Ok, does it have a Run/Tow switch under the seat?
If the little pigtail comes off the end of the motor, that is the speed sensor, which is for regen braking...
No switch, looked very well.

Previous owner may have removed it???

The F/R switch is toggle not a lever type like I have on my 2000
Jimbo2012 is offline   Reply With Quote
Old 09-19-2013, 12:22 PM   #6
joesam
Gone Wild
Club Car
 
Join Date: Sep 2012
Location: Chestermere, Alberta - Canada
Posts: 1,146
Default Re: Can't move at all - Help

My '96 Regen 1 has no run/tow switch - not sure if early '97's might not have had one either. But your controller sounds different. Mine is Black "T" shaped. Somehow a relay is attached to the key switch on mine which performs the run/tow function when switched on. But, my motor does have a pigtail which connects to the controller (Regen function). If you have a rocker switch F/W it is absolutely a Regen model (though it might have been modified).
joesam is offline   Reply With Quote
Old 09-21-2013, 10:28 AM   #7
cmalberto
Gone Wild
 
cmalberto's Avatar
Club Car
 
Join Date: Jun 2013
Location: Beaumont, Texas
Posts: 154
Default Re: Can't move at all - Help

Mine clicks when I turn the key on AND when I press the goPedal. However, I have an aftermarket Solenoid and Controller. Not sure I remember when it was stock - hope that helps.
cmalberto is offline   Reply With Quote
Old 09-22-2013, 11:17 AM   #8
crash test dummy
Guest
 
Posts: n/a
Default Re: Can't move at all - Help

JACK UP CART REAR BEFORE TESTING SOLENOID !!!

photos of controller and solenoid area would help
  Reply With Quote
Old 09-22-2013, 12:02 PM   #9
Storm S
Gone Wild
 
Storm S's Avatar
Club Car
 
Join Date: Aug 2013
Location: PBG, Florida
Posts: 247
Default Re: Can't move at all - Help

Quote:
Originally Posted by crash test dummy View Post
JACK UP CART REAR BEFORE TESTING SOLENOID !!!

photos of controller and solenoid area would help
Did I leave that out? Crap! Thank you for the catch! I meant to put that in there. There is a chance of things sticking and the cart running off. lol
Storm S is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1996 Series DS 48V won't move on ground, wheels barely move on jacks Electric Club Car
Tries to move Electric Club Car
97 txt will not move Electric EZGO
won't move Electric EZGO


All times are GMT -5. The time now is 05:14 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.