lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-11-2010, 08:53 PM   #1
ef13
Not Yet Wild
 
Join Date: Sep 2010
Location: Muskegon, MI
Posts: 5
Default 87 ezgo 244cc hard starting and "doggy"

this is an 87 with the robin 244cc engine. Starts kinda hard and when it does seems slow or doggy. Seems to have more speed in reverse(or maybe seems)

things I have done already-
compression- 118
pulled carb soaked and blew out with compressor
checked float level
Rebuilt fuel pump
New NGK plug
nice good spark

Any help would be great!!
ef13 is offline   Reply With Quote
Old 09-11-2010, 09:03 PM   #2
Pocono Country Boy
Gone Wild
 
Pocono Country Boy's Avatar
E-Z-GO
 
Join Date: Aug 2010
Location: Pocono Mountains, PA
Posts: 162
Default Re: 87 ezgo 244cc hard starting and "doggy"

Did you remove the jets from the carb and clear all the little holes in them when you had the carb off?

Did you check and/or replace the fuel lines and filters?

Does the motor spool up sluggish or is it spooling up ok but the cart's just not taking off?
Pocono Country Boy is offline   Reply With Quote
Old 09-11-2010, 10:47 PM   #3
ef13
Not Yet Wild
 
Join Date: Sep 2010
Location: Muskegon, MI
Posts: 5
Default Re: 87 ezgo 244cc hard starting and "doggy"

Yes all jets were pulled and cleaned.
new fuel line filter seemed fine.
spool up?? revs up sluggish, will take off, but is slow and I dont think its coming up to full rpm.

onces it gets going and then i slow down almost to a stop, it wont go anymore push the gas down and it justs chuggs at an idle speed. seems like too much fuel, but not too sure.
ef13 is offline   Reply With Quote
Old 09-12-2010, 06:12 AM   #4
1moretoy
Never really finished
 
1moretoy's Avatar
Mixed Breed
 
Join Date: Jun 2010
Location: Georgia
Posts: 1,102
Default Re: 87 ezgo 244cc hard starting and "doggy"

make sure the small overflow hole in the carb is not plugged or capped...it wont run if it is. I put a small vent hose on mine to keep crud from getting in and it got crimped causing it to stop running except at idle
1moretoy is offline   Reply With Quote
Old 09-12-2010, 07:06 AM   #5
Pocono Country Boy
Gone Wild
 
Pocono Country Boy's Avatar
E-Z-GO
 
Join Date: Aug 2010
Location: Pocono Mountains, PA
Posts: 162
Default Re: 87 ezgo 244cc hard starting and "doggy"

When you checked the float level did you adjust it or leave it as it was?

Silly question I know, but did the needle make it back into the valve seat when reassembling the carb? (happened to me once when I was in a hurry!)

It does sound like it might be flooding to me.
Pocono Country Boy is offline   Reply With Quote
Old 09-12-2010, 01:38 PM   #6
BrewCityMusic
Hammer Down !!!!
 
BrewCityMusic's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Lake Geneva, WI
Posts: 2,681
Default Re: 87 ezgo 244cc hard starting and "doggy"

If none of the above ideas help, just for fun, loosen or remove the bolts holding the exhaust pipe to the muffler so there's a gap between them and see if it runs better - 2pg mufflers like to get all gunked up and plugged after awhile. If that does help, search the threads for "muffler bbq" for directions how to burn the muffler clean again
BrewCityMusic is offline   Reply With Quote
Old 09-12-2010, 02:09 PM   #7
ef13
Not Yet Wild
 
Join Date: Sep 2010
Location: Muskegon, MI
Posts: 5
Default Re: 87 ezgo 244cc hard starting and "doggy"

Yes overflows/vents are clear

Didnt have to adjust the float, was good. Yes the needdle and seat were working after reassembly, I always check that on every carb I redo.

I will check the muffler thing in a bit.
ef13 is offline   Reply With Quote
Old 09-12-2010, 04:02 PM   #8
ef13
Not Yet Wild
 
Join Date: Sep 2010
Location: Muskegon, MI
Posts: 5
Default Re: 87 ezgo 244cc hard starting and "doggy"

well tried it again toda with muffler seperated, seemed better. put it back on and problem came back, no acceleration/power after I would slow down and try to go again. took it back off and power was back.

so....I think its time for a BBQ!!!!! agree?
ef13 is offline   Reply With Quote
Old 09-12-2010, 05:26 PM   #9
BrewCityMusic
Hammer Down !!!!
 
BrewCityMusic's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Lake Geneva, WI
Posts: 2,681
Default Re: 87 ezgo 244cc hard starting and "doggy"

ROAST IT !!!!! search the forums for "muffler BBQ", grab some matches and a six-pack and give it a shot, it worked wonders for my cart!
BrewCityMusic is offline   Reply With Quote
Old 09-25-2010, 11:31 PM   #10
ef13
Not Yet Wild
 
Join Date: Sep 2010
Location: Muskegon, MI
Posts: 5
Default Re: 87 ezgo 244cc hard starting and "doggy"

Well, no luck with bbqing it, guess it will need a new one. Thanks for all of your help!!!
ef13 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
G9- Won't quit "starting"... Gas Yamaha
"slow" Precedent "need Speed" Gas Club Car
Wheels and Tires in So Cal 22" paddles on Douglas, 25" Dunlop on ITP, 27" ITP's Golf Carts and Parts


All times are GMT -5. The time now is 04:07 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.