lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 05-08-2010, 01:21 PM   #1
stopsign
Not Yet Wild
 
stopsign's Avatar
E-Z-GO
 
Join Date: Apr 2010
Location: Avoca, PA
Posts: 31
Default Changed accelerator cable... Too snappy now, proper adjectment advice needed...

Hi guys.... new to golf cart but definitely not to turning wrenches... just like doing things right the first time... I changed the accelerator cable on my 'new' 1990 Marathon and i put it on just as the previous however i have no slow speed... i mean other carts i drove i was able to just putt around very slow speed when needed... i have alot of slack in it but not sure how to adjust govener/cable.... soon as the pedal is depressed even slightly the cart takes off pretty quickly... when you try and let off to just go slow it reaches the point where the engine shuts off rather then hold a slow speed so to go slow it basically engine on/engine off, repeat rather then a basic idle kinda speed... how can i make sure everything is in proper adjustment ?
stopsign is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 05-08-2010, 08:19 PM   #2
ez go go
Doin' the Wild Thang
 
ez go go's Avatar
E-Z-GO
 
Join Date: Mar 2010
Location: Greenville, AL
Posts: 1,063
Default Re: Changed accelerator cable... Too snappy now, proper adjectment advice needed...

This sounds like a clutch issue to me. I had a 4 stroke that had the same issue. Terribly jumply to the touch of the pedal. A faulty primary clutch was my problem. A damaged power spring was stopping the clutch from engaging at a proper rpm. As soon as the pedal was touched, off we go.
ez go go is offline   Reply With Quote
Old 05-10-2010, 10:33 AM   #3
GoTeeMan
EZ Like Sunday Morning
 
GoTeeMan's Avatar
E-Z-GO
 
Join Date: Jun 2009
Location: Owatonna, Minnesota
Posts: 465
Default Re: Changed accelerator cable... Too snappy now, proper adjectment advice needed...

Sorry ez-go-go but this one is easy. When you have the cable installed correctly there should be a spring between the cable stop and the throttle lever. This spring should be compressed when you have nothing touching the accel pedal.

How it is supposed to work: When you start to push the pedal the spring holds the throttle closed to get you past the microswitch in the pedal, then once you have pushed the pedal far enough the throttle begins to open and the cart will start, you can now have very little throttle movement and drive very slowly without turning the cart on and off when you are trying to go slowly.

Look up member "EZGOMIKE" and he can get you the right spring.

Goodluck
GoTeeMan is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Quick advice needed! Gas EZGO
Accelerator Cable Gas EZGO
IMMEDIATE ADVICE NEEDED! 36 or 48volt? Electric EZGO
1991 Par Car Accelerator cable Gas Columbia ParCar
How do I properly adjust accelerator cable? Gas EZGO


All times are GMT -5. The time now is 09:49 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.