lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-16-2022, 01:56 PM   #1
wmacree0807
Not Yet Wild
 
Join Date: May 2017
Posts: 55
Default 2013 EZGO TXT48 Solenoid not activating

I have a 2013 EZGO TXT 48 :

Brand New Wiring Harness
New Solenoid
New Charger receptacle

Iím not activating the solenoid, Iíve used the diagram provided and I found I am not getting positive voltage anywhere past the battery pack.

No positive voltage at the run tow switch, key switch, pedal switch, fr switch.

If Iím understanding correctly, positive voltage goes directly from the battery pack to the run tow switch to start the activation circuit, but I have no voltage there at all.

Iím stumped as to where or how Iím losing power.

Any help would be appreciated.

Also I attached an image of the harness that I ordered. This may have something to do with it, I circled a connector that is coming out of the 16 pin main plug. Iím not sure the purpose of this and Iím wondering if I ordered the wrong harness.
Attached Images
File Type: jpg 5322420A-B3D9-46C8-88A8-1E3231C11105.jpg (30.7 KB, 0 views)
wmacree0807 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-16-2022, 02:18 PM   #2
Volt_Ampere
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 5,892
Default Re: 2013 EZGO TXT48 Solenoid not activating

There could be a blown fuse. Since wiring harness is new, also suspect that. Make sure diode(s) are installed correctly.
Volt_Ampere is offline   Reply With Quote
Old 07-16-2022, 02:58 PM   #3
wmacree0807
Not Yet Wild
 
Join Date: May 2017
Posts: 55
Default Re: 2013 EZGO TXT48 Solenoid not activating

Quote:
Originally Posted by Volt_Ampere View Post
There could be a blown fuse. Since wiring harness is new, also suspect that. Make sure diode(s) are installed correctly.
Are you in talking about an internal fuse on the wiring harness?

Also did you see the 3 pin molex plug I circled? Any idea what that is for?
wmacree0807 is offline   Reply With Quote
Old 07-16-2022, 05:00 PM   #4
Volt_Ampere
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 5,892
Default Re: 2013 EZGO TXT48 Solenoid not activating

I don't have a wiring diagram for your cart. That's what you need to consult.
Volt_Ampere is offline   Reply With Quote
Old 07-16-2022, 07:11 PM   #5
wmacree0807
Not Yet Wild
 
Join Date: May 2017
Posts: 55
Default Re: 2013 EZGO TXT48 Solenoid not activating

Quote:
Originally Posted by Volt_Ampere View Post
I don't have a wiring diagram for your cart. That's what you need to consult.
Here is the wiring diagram with the solenoid activation highlighted, I donít have positive voltage anywhere passed the initial Battery pack on the red lines.
Attached Images
File Type: jpg F66B1826-80AD-4B01-BEE5-EBEAF6B3931D.jpg (33.2 KB, 0 views)
wmacree0807 is offline   Reply With Quote
Old 07-16-2022, 07:57 PM   #6
Volt_Ampere
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 5,892
Default Re: 2013 EZGO TXT48 Solenoid not activating

You should have positive voltage from battery negative to the solenoid as shown in your wiring diagram. There is only one wire to trace out there assuming all of your batteries are connected.
Volt_Ampere is offline   Reply With Quote
Old 07-16-2022, 08:08 PM   #7
wmacree0807
Not Yet Wild
 
Join Date: May 2017
Posts: 55
Default Re: 2013 EZGO TXT48 Solenoid not activating

Quote:
Originally Posted by Volt_Ampere View Post
You should have positive voltage from battery negative to the solenoid as shown in your wiring diagram. There is only one wire to trace out there assuming all of your batteries are connected.
Yes that is why Iím stumped. I have full pack voltage, 50.3 volts. But I dont have any voltage going to the Run tow switch, or anything after that. I donít know if pack voltage runs through anything before the run tow switch but I canít find where or why Iím losing power.
wmacree0807 is offline   Reply With Quote
Old 07-19-2022, 03:26 PM   #8
Kortoga
Getting Wild
E-Z-GO
 
Join Date: Apr 2015
Location: The Tardis
Posts: 79
Default Re: 2013 EZGO TXT48 Solenoid not activating

Quote:
Originally Posted by wmacree0807 View Post
Yes that is why Iím stumped. I have full pack voltage, 50.3 volts. But I dont have any voltage going to the Run tow switch, or anything after that. I donít know if pack voltage runs through anything before the run tow switch but I canít find where or why Iím losing power.
Did you find your problem? If so, great! What was it? I am curious.

If not, you say you are not getting pack voltage at the Tow Switch. There "should not" be anything between the Batteries and Tow Switch. Someone could have put a fuse between the batteries and the Tow switch that is blown.

The Tow switch basically turns off all voltage to the cart's controls.
Are you shooting voltage up to the Tow switch OR right after the Tow switch? Is your Tow switch working properly or wired up properly with the new wiring you are talking about? The wiring goes through pins 1 & 2 on the Tow switch plug connector. Check to make sure this plug is connected good and the pins are not pushed out (not making connection).
Kortoga is offline   Reply With Quote
Reply

Tags
48 volt, curtis, ezgo, solenoid, txt
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZGO Series TXT 36V Solenoid Not Activating Electric EZGO
EX-GO 36v cart, solenoid not activating, solved Electric EZGO
ezgo pds f/r rocker switch activating solenoid Electric EZGO
ezgo txt48 solenoid rattle Electric EZGO
Solenoid Not Activating? Electric EZGO


All times are GMT -5. The time now is 09:25 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.