lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-17-2010, 04:14 PM   #1
sinjin
Not Yet Wild
 
Join Date: Mar 2010
Posts: 2
Default help! engine keeps running after let off gas

Hi newbie here. I have a 1994 medalist gas that I am having a issue with. When i let of the gas pedal it wants to keep running and driving. pumping the gas pedal a couple times usually gets it to shut off. What do I need to check/adjust/replace to resolve this, almost put it through the front of the garage yesterday. At least I know the brakes work well
sinjin is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
G9 With poor running engine Gas Yamaha
Question for anyone running a Honda engine Big Block Talk!
2 Stroke running engine temperature Gas EZGO
01' CC w/ 290 engine running intermittently Gas Club Car
Engine tries to keep running Gas Club Car


All times are GMT -5. The time now is 07:21 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.